lcd4linux fixes:
authorNicolas Thill <nico@openwrt.org>
Mon, 4 Aug 2008 14:56:45 +0000 (14:56 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 4 Aug 2008 14:56:45 +0000 (14:56 +0000)
 - lcd4linux needs at least 1 driver & 1 plugin enabled, assume all drivers & plugins are wanted when none are selected
 - since enabling all plugins prevents lcd4linux from building, enable only the NULL driver until we can figure something better
 - bump release number

SVN-Revision: 12094

utils/lcd4linux/Config.in
utils/lcd4linux/Makefile

index c846af1835eb31893ea98a97eab6e623b4b9b7f3..471c6da0fffbe71037dcc412a707038be3126d53 100644 (file)
@@ -67,6 +67,7 @@ config LCD4LINUX_DRV_Noritake
 config LCD4LINUX_DRV_NULL
        bool
        prompt "NULL"
+       default y
 
 config LCD4LINUX_DRV_PNG
        bool
index c65fe07c2a251a01c08de0b60c7b61ceb94e9316..86c75518c0b23b77fd7c8d2f9ad6f0f9d6aff66f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=lcd4linux
 PKG_REV:=877
 PKG_VERSION:=r$(PKG_REV)
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://ssl.bulix.org/svn/lcd4linux/trunk/
@@ -29,6 +29,7 @@ define Package/lcd4linux
   DEPENDS:=+libusb
   TITLE:=LCD display utility
   URL:=http://lcd4linux.bulix.org/
+  MENU:=1
 endef
 
 define Package/lcd4linux/config
@@ -178,7 +179,14 @@ ifneq ($(CONFIG_LCD4LINUX_PLUGIN_mysql),)
 PKG_BUILD_DEPENDS += libmysqlclient
 endif
 
-
+# XXX: lcd4linux needs at least one driver and one plugin, if none are selected, build'em all
+ifeq ($(strip $(LCD4LINUX_CONFIGURE_DRIVERS)),)
+  LCD4LINUX_CONFIGURE_DRIVERS:=all
+endif  
+ifeq ($(strip $(LCD4LINUX_CONFIGURE_PLUGINS)),)
+  LCD4LINUX_CONFIGURE_PLUGINS:=all
+endif  
+  
 ## TODO PYTHON PLUGIN, DEPENDS on ver >= '2.1.0'
 
 
@@ -188,13 +196,13 @@ EXTRA_LDFLAGS+=-L$(STAGING_DIR)/usr/lib -Wl,-rpath-link,$(STAGING_DIR)/usr/lib -
 TARGET_CONFIGURE_OPTS+=\
        CC="$(TARGET_CC) $(EXTRA_CFLAGS) $(EXTRA_LDFLAGS)"
 
-
 CONFIGURE_ARGS += \
        --without-x \
        --without-python \
-       --with-drivers="$(LCD4LINUX_CONFIGURE_DRIVERS)" \
-       --with-plugins="$(LCD4LINUX_CONFIGURE_PLUGINS)" \
        --disable-rpath \
+       --with-drivers="$(strip $(LCD4LINUX_CONFIGURE_DRIVERS))" \
+       --with-plugins="$(strip $(LCD4LINUX_CONFIGURE_PLUGINS))" \
+
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install