mac80211: mark mac80211-hwsim 80211BE capable
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 20 Oct 2024 22:06:46 +0000 (00:06 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 20 Oct 2024 22:06:46 +0000 (00:06 +0200)
Build hostapd with 80211BE suport.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/mac80211/Makefile

index 7f1cb7f38fea818bc806203726d215a9617c77db..22cd0e97b4177008db96a19b76b7631307685973 100644 (file)
@@ -171,7 +171,7 @@ endef
 define KernelPackage/mac80211-hwsim
   $(call KernelPackage/mac80211/Default)
   TITLE:=mac80211 HW simulation device
-  DEPENDS+= +kmod-mac80211 +@DRIVER_11AX_SUPPORT +@DRIVER_11AC_SUPPORT
+  DEPENDS+= +kmod-mac80211 +@DRIVER_11BE_SUPPORT +@DRIVER_11AX_SUPPORT +@DRIVER_11AC_SUPPORT
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/virtual/mac80211_hwsim.ko
   AUTOLOAD:=$(call AutoProbe,mac80211_hwsim)
 endef