liboping: update to 1.6.2
authorStephen Walker <stephendwalker@gmail.com>
Sun, 27 May 2012 02:12:17 +0000 (02:12 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Sun, 27 May 2012 02:12:17 +0000 (02:12 +0000)
SVN-Revision: 31869

libs/liboping/Makefile
libs/liboping/patches/01-no-werror.patch

index 89ec7fe0c31e3acbaa25093923c1645607bda70a..5ed5f7aa0b8b55fddb437bba18a71d9ee56f9a9b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2011 OpenWrt.org
+# Copyright (C) 2009-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,18 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=liboping
-PKG_VERSION:=1.6.1
+PKG_VERSION:=1.6.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://verplant.org/liboping/files
-PKG_MD5SUM:=748554a18e1771913f4f402ee9f957c9
+PKG_MD5SUM:=64a6f31310093d2517cfe7f05aa011e0
 
 PKG_FIXUP:=libtool
 
 PKG_INSTALL:=1
 
-include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
 
 define Package/liboping/Default
index 2cbcd20cf49ce68d45df6ac461a7ae8a777db5bd..85892849dd3bd045520037def151e765cfa85e09 100644 (file)
@@ -1,9 +1,11 @@
---- liboping-1.6.0.org/src/Makefile.am 2011-01-26 14:18:42.000000000 +0100
-+++ liboping-1.6.0/src/Makefile.am     2011-01-27 13:23:27.716204995 +0100
-@@ -4,5 +4,5 @@ SUBDIRS = mans
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS = foreign no-dependenci
+ SUBDIRS = mans
  
  if COMPILER_IS_GCC
 -AM_CFLAGS = -Wall -Werror
 +AM_CFLAGS = -Wall
  endif
  
+ include_HEADERS = oping.h