tinyproxy: allow to use the bind option Attached patch allows to use the 'bind' optio...
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 24 May 2011 09:09:58 +0000 (09:09 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 24 May 2011 09:09:58 +0000 (09:09 +0000)
Regards
Mathias

SVN-Revision: 26982

net/tinyproxy/Makefile
net/tinyproxy/patches/010-no-docs-and-tests.patch
net/tinyproxy/patches/020-config_and_pid-path.patch
net/tinyproxy/patches/030-allow_bind_in_transparent_mode.patch [new file with mode: 0644]

index f219a094d99fa0ba7dd40e66d1b8c7eecf70739e..e3dae220499d191639bc61e7a534349ca85e3e3e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinyproxy
 PKG_VERSION:=1.8.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.banu.com/pub/tinyproxy/1.8/
index 12298e657de52bda1bac850e11eec4be1dcf8a3c..9845c351c2273ac46101e52ea0eec9a5799b4445 100644 (file)
@@ -12,7 +12,7 @@
  ACLOCAL_AMFLAGS = -I m4macros
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -221,9 +221,7 @@ SUBDIRS = \
+@@ -222,9 +222,7 @@ SUBDIRS = \
        src \
        data \
        etc \
index 2e9f9e48c0eeb68c6427ed8b29e74148f775e3ea..3ab7482a4e65f7c50b7a22fa785ce281aca37560 100644 (file)
@@ -1,7 +1,6 @@
-diff -Nur a/src/main.c b/src/main.c
---- a/src/main.c        2010-07-17 11:57:25.000000000 +0200
-+++ b/src/main.c        2010-07-17 11:58:52.000000000 +0200
-@@ -326,8 +326,8 @@
+--- a/src/main.c
++++ b/src/main.c
+@@ -326,8 +326,8 @@ static void initialize_config_defaults (
          conf->errorpages = NULL;
          conf->stathost = safestrdup (TINYPROXY_STATHOST);
          conf->idletimeout = MAX_IDLE_TIME;
@@ -12,4 +11,3 @@ diff -Nur a/src/main.c b/src/main.c
  }
  
  /**
-
diff --git a/net/tinyproxy/patches/030-allow_bind_in_transparent_mode.patch b/net/tinyproxy/patches/030-allow_bind_in_transparent_mode.patch
new file mode 100644 (file)
index 0000000..7d6decd
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/src/conf.c
++++ b/src/conf.c
+@@ -857,7 +857,6 @@ static HANDLE_FUNC (handle_deny)
+ static HANDLE_FUNC (handle_bind)
+ {
+-#ifndef TRANSPARENT_PROXY
+         int r = set_string_arg (&conf->bind_address, line, &match[2]);
+         if (r)
+@@ -865,11 +864,6 @@ static HANDLE_FUNC (handle_bind)
+         log_message (LOG_INFO,
+                      "Outgoing connections bound to IP %s", conf->bind_address);
+         return 0;
+-#else
+-        fprintf (stderr,
+-                 "\"Bind\" cannot be used with transparent support enabled.\n");
+-        return 1;
+-#endif
+ }
+ static HANDLE_FUNC (handle_listen)