#
-# Copyright (C) 2007-2011 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
include $(TOPDIR)/rules.mk
PKG_NAME:=pciutils
-PKG_VERSION:=3.1.7
-PKG_RELEASE:=3
+PKG_VERSION:=3.1.9
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
-PKG_MD5SUM:=35222edb86b50a6641352c66fe829b2e
+PKG_MD5SUM:=79cc1d0bff8603d3a550fa63802cd1db
PKG_INSTALL:=1
endef
define Package/pciutils/description
- This package contains various utilities for inspecting and setting of
- devices connected to the PCI bus.
+ contains collection of programs for inspecting and manipulating configuration
+ of PCI devices
endef
define Package/pciutils/postinst
--- a/update-pciids.sh
+++ b/update-pciids.sh
@@ -6,9 +6,8 @@ set -e
- SRC="http://pciids.sourceforge.net/v2.2/pci.ids"
+ SRC="http://pci-ids.ucw.cz/v2.2/pci.ids"
DEST=pci.ids
PCI_COMPRESSED_IDS=
-GREP=grep
if ! touch ${DEST} >/dev/null 2>&1 ; then
${quiet} || echo "${DEST} is read-only, exiting." 1>&2
@@ -18,7 +17,7 @@ fi
- if [ -n "$PCI_COMPRESSED_IDS" ] ; then
+ if [ "$PCI_COMPRESSED_IDS" -eq 1 ] ; then
DECOMP="cat"
SRC="$SRC.gz"
- GREP=zgrep