projects
/
openwrt
/
staging
/
robimarko.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
468a9b7
)
build: add template for installing device .dtb files
author
Felix Fietkau
<nbd@nbd.name>
Sun, 31 Jul 2016 17:25:32 +0000
(19:25 +0200)
committer
Felix Fietkau
<nbd@nbd.name>
Sun, 31 Jul 2016 17:35:05 +0000
(19:35 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/image-commands.mk
patch
|
blob
|
history
diff --git
a/include/image-commands.mk
b/include/image-commands.mk
index 790e9297ca66840ae0446b95cb13f7a7fa67b058..160b5d883395d3ef53f4c61426ea27a5dbd3a063 100644
(file)
--- a/
include/image-commands.mk
+++ b/
include/image-commands.mk
@@
-46,6
+46,14
@@
define Build/append-dtb
cat $@.dtb >> $@
endef
+define Build/install-dtb
+ $(foreach dts,$(DEVICE_DTS), \
+ $(CP) \
+ $(DTS_DIR)/$(dts).dtb \
+ $(BIN_DIR)/$(IMG_PREFIX)-$(dts).dtb; \
+ )
+endef
+
define Build/fit
$(TOPDIR)/scripts/mkits.sh \
-D $(DEVICE_NAME) -o $@.its -k $@ \