media: coda: remove -I$(src) header search path
authorMasahiro Yamada <yamada.masahiro@socionext.com>
Fri, 25 Jan 2019 06:54:17 +0000 (01:54 -0500)
committerMauro Carvalho Chehab <mchehab+samsung@kernel.org>
Thu, 23 May 2019 16:04:00 +0000 (12:04 -0400)
Remove the header search path to the current directory.

The compiler will search headers in the current directory by
using #include "..." instead of #include <...>

Also, change TRACE_INCLUDE_PATH to point to the location of trace.h.

Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
Signed-off-by: Mauro Carvalho Chehab <mchehab+samsung@kernel.org>
drivers/media/platform/coda/Makefile
drivers/media/platform/coda/coda-h264.c
drivers/media/platform/coda/trace.h

index 858284328af9dae700a43b1db3b64fce5a99f398..3eed821372576b6d8789550cfacfeb0165d7244d 100644 (file)
@@ -1,5 +1,3 @@
-ccflags-y += -I$(src)
-
 coda-objs := coda-common.o coda-bit.o coda-gdi.o coda-h264.o coda-jpeg.o
 
 obj-$(CONFIG_VIDEO_CODA) += coda.o
index 635356a839cf403c5de33de3e800611221358410..6da82d13eb2179947ed98667d1a101f4196c2e4e 100644 (file)
@@ -14,7 +14,8 @@
 #include <linux/kernel.h>
 #include <linux/string.h>
 #include <linux/videodev2.h>
-#include <coda.h>
+
+#include "coda.h"
 
 static const u8 coda_filler_size[8] = { 0, 7, 14, 13, 12, 11, 10, 9 };
 
index a672bfc4c6ba92dcdffe38891198981ebf399a8a..6cf58237fff2f5419317407d35bc76da65ec9177 100644 (file)
@@ -157,7 +157,7 @@ DEFINE_EVENT(coda_buf_meta_class, coda_dec_rot_done,
 #endif /* __CODA_TRACE_H__ */
 
 #undef TRACE_INCLUDE_PATH
-#define TRACE_INCLUDE_PATH .
+#define TRACE_INCLUDE_PATH ../../drivers/media/platform/coda
 #undef TRACE_INCLUDE_FILE
 #define TRACE_INCLUDE_FILE trace