projects
/
openwrt
/
staging
/
thess.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
f432353
)
build: add SUBDIR_MAKE_DEBUG variable to make it easier to debug package makefiles
author
Felix Fietkau
<nbd@nbd.name>
Thu, 4 Nov 2021 14:53:50 +0000
(15:53 +0100)
committer
Felix Fietkau
<nbd@nbd.name>
Thu, 4 Nov 2021 15:43:32 +0000
(16:43 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/subdir.mk
patch
|
blob
|
history
diff --git
a/include/subdir.mk
b/include/subdir.mk
index d33b947fdf8eb64a0d44b13615c3336609a5fb4a..155f4935384f0f2f7ece9012b3a46267fa5a3700 100644
(file)
--- a/
include/subdir.mk
+++ b/
include/subdir.mk
@@
-27,7
+27,7
@@
lastdir=$(word $(words $(subst /, ,$(1))),$(subst /, ,$(1)))
diralias=$(if $(findstring $(1),$(call lastdir,$(1))),,$(call lastdir,$(1)))
subdir_make_opts = \
- -r -C $(1) \
+
$(if $(SUBDIR_MAKE_DEBUG),-d)
-r -C $(1) \
BUILD_SUBDIR="$(1)" \
BUILD_VARIANT="$(4)" \
ALL_VARIANTS="$(5)"