realtek: build sane factory images for DGS-1210 models
authorMarkus Stockhausen <markus.stockhausen@gmx.de>
Wed, 6 Jul 2022 11:43:23 +0000 (13:43 +0200)
committerLuiz Angelo Daros de Luca <luizluca@gmail.com>
Sat, 9 Jul 2022 01:10:16 +0000 (22:10 -0300)
During upload of firmware images the WebUI and CLI patch process
extracts a version information from the uploaded file and stores it
onto the jffs2 partition. To be precise it is written into the
flash.txt or flash2.txt files depending on the selected target image.
This data is not used anywhere else. The current OpenWrt factory
image misses this label. Therefore version information shows only
garbage. Fix this.

Before:
DGS-1210-20> show firmware information
IMAGE ONE:
Version      : xfo/QE~WQD"A\Scxq...
Size         : 5505185 Bytes

After:
DGS-1210-20> show firmware information
IMAGE ONE:
Version      : OpenWrt
Size         : 5505200 Bytes

Tested-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Signed-off-by: Markus Stockhausen <markus.stockhausen@gmx.de>
(cherry picked from commit fae3ac3560459320a88be86b31c572c4bca42645)

target/linux/realtek/image/Makefile
target/linux/realtek/image/rtl838x.mk

index 3a1ba2f60e81c9cae4ef7560629d86fe53f25b02..cf779002e86ee6e65bc2e991a6c9ce4d529ce388 100644 (file)
@@ -21,6 +21,11 @@ define Build/dlink-cameo
        $(SCRIPT_DIR)/cameo-tag.py $@ $(DLINK_KERNEL_PART_SIZE)
 endef
 
+define Build/dlink-version
+       echo -n "OpenWrt" >> $@
+       dd if=/dev/zero bs=25 count=1 >> $@
+endef
+
 define Build/dlink-headers
         dd if=$@ bs=$(DLINK_KERNEL_PART_SIZE) count=1 of=$@.kernel_part; \
         dd if=$@ bs=$(DLINK_KERNEL_PART_SIZE) skip=1 of=$@.rootfs_part; \
index d72dc2191bf6a6fd65848604671cb6d7dfed8644..b0f307296de49d9268edbcb842b15ac762afa0d2 100644 (file)
@@ -23,7 +23,8 @@ define Device/d-link_dgs-1210
   CAMEO_BOARD_VERSION := 32
   IMAGES += factory_image1.bin
   IMAGE/factory_image1.bin := append-kernel | pad-to 64k | \
-       append-rootfs | pad-rootfs | pad-to 16 | check-size | dlink-headers
+       append-rootfs | pad-rootfs | pad-to 16 | check-size | \
+       dlink-version | dlink-headers
 endef
 
 define Device/d-link_dgs-1210-10p