Revert "compat-wireless: fix rfkill patches from applying"
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 22 May 2011 10:47:05 +0000 (12:47 +0200)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Mon, 23 May 2011 21:05:11 +0000 (14:05 -0700)
The commit was removed from linux-next, so this backport patch should also be removed.

This reverts commit b8e46e19937710d2ae14731871cf8c45a0fc9d74.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
config.mk
defconfigs/atheros-debug.mk
patches/03-rfkill.patch

index ce67176fbacf70e82d1f0f8aec54c2a75ed65f0c..99485a4893d184eb649822462999f16026c6097e 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -626,5 +626,6 @@ CONFIG_RFKILL_BACKPORT=m
 ifdef CONFIG_LEDS_TRIGGERS
 CONFIG_RFKILL_BACKPORT_LEDS=y
 endif #CONFIG_LEDS_TRIGGERS
+CONFIG_RFKILL_BACKPORT_INPUT=y
 endif #CONFIG_COMPAT_KERNEL_31
 
index 8850df54650541f42b2777a6ccf8b7481eae695b..d9534eb1c90e847048ee816546af541df5f609f4 100644 (file)
@@ -587,5 +587,6 @@ endif #CONFIG_COMPAT_KERNEL_27
 ifdef CONFIG_COMPAT_KERNEL_31
 CONFIG_RFKILL_BACKPORT=m
 CONFIG_RFKILL_BACKPORT_LEDS=y
+CONFIG_RFKILL_BACKPORT_INPUT=y
 endif #CONFIG_COMPAT_KERNEL_31
 
index e623a358cfbdde024ea341f2e7d0cef27f5e3a5f..a13dd9a7a5897d6881de9b394df59f86ab324ee3 100644 (file)
@@ -35,11 +35,23 @@ This would do the policing from within mac80211.
  #
  
 -rfkill-y                      += core.o
+-rfkill-$(CONFIG_RFKILL_INPUT) += input.o
 -obj-$(CONFIG_RFKILL)          += rfkill.o
-+rfkill_backport-y             += core.o
-+obj-$(CONFIG_RFKILL_BACKPORT) += rfkill_backport.o
++rfkill_backport-y                     += core.o
++rfkill_backport-$(CONFIG_RFKILL_BACKPORT_INPUT)       += input.o
++obj-$(CONFIG_RFKILL_BACKPORT)         += rfkill_backport.o
  obj-$(CONFIG_RFKILL_REGULATOR)        += rfkill-regulator.o
- obj-$(CONFIG_RFKILL_GPIO)     += rfkill-gpio.o
+--- a/net/rfkill/input.c
++++ b/net/rfkill/input.c
+@@ -232,7 +232,7 @@ static int rfkill_connect(struct input_h
+       handle->dev = dev;
+       handle->handler = handler;
+-      handle->name = "rfkill";
++      handle->name = "rfkill_backport";
+       /* causes rfkill_start() to be called */
+       error = input_register_handle(handle);
 --- a/net/rfkill/core.c
 +++ b/net/rfkill/core.c
 @@ -658,7 +658,7 @@ static int rfkill_resume(struct device *