projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b902284
)
imagebuilder: fix APK keys dir creation
author
Kuan-Yi Li
<kyli@abysm.org>
Wed, 13 Nov 2024 16:29:21 +0000
(
00:29
+0800)
committer
Christian Marangi
<ansuelsmth@gmail.com>
Wed, 13 Nov 2024 16:42:04 +0000
(17:42 +0100)
Make keys directory for APK instead of OPKG while adding local key.
Signed-off-by: Kuan-Yi Li <kyli@abysm.org>
Link:
https://github.com/openwrt/openwrt/pull/16942
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
target/imagebuilder/files/Makefile
patch
|
blob
|
history
diff --git
a/target/imagebuilder/files/Makefile
b/target/imagebuilder/files/Makefile
index c92ab7430663b71cfa6626caa1576ce9fe17e8f5..56f761e966acb184a4002c0d1fb3a2ff34aa8969 100644
(file)
--- a/
target/imagebuilder/files/Makefile
+++ b/
target/imagebuilder/files/Makefile
@@
-249,7
+249,7
@@
ifeq ($(CONFIG_USE_APK),)
else
$(if $(CONFIG_SIGNATURE_CHECK), \
$(if $(ADD_LOCAL_KEY), \
- mkdir -p $(TARGET_DIR)/etc/
opkg
/keys/; \
+ mkdir -p $(TARGET_DIR)/etc/
apk
/keys/; \
cp $(BUILD_KEY_APK_PUB) $(TARGET_DIR)/etc/apk/keys/; \
) \
)