[packages] collectd: fix bogus -ltdl dependency
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 12 Dec 2010 17:37:59 +0000 (17:37 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 12 Dec 2010 17:37:59 +0000 (17:37 +0000)
SVN-Revision: 24517

utils/collectd/patches/002-fix-ltdl-linking.patch [new file with mode: 0644]
utils/collectd/patches/100-rrdtool-add-rrasingle-option.patch

diff --git a/utils/collectd/patches/002-fix-ltdl-linking.patch b/utils/collectd/patches/002-fix-ltdl-linking.patch
new file mode 100644 (file)
index 0000000..359ed91
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -85,7 +85,7 @@ endif
+ if BUILD_WITH_OWN_LIBOCONFIG
+ collectd_LDADD += $(LIBLTDL) liboconfig/liboconfig.la
+-collectd_DEPENDENCIES += $(LIBLTDL) liboconfig/liboconfig.la
++collectd_DEPENDENCIES += liboconfig/liboconfig.la
+ else
+ collectd_LDADD += -loconfig
+ endif
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -57,7 +57,7 @@ bin_PROGRAMS = collectd-nagios$(EXEEXT)
+ @BUILD_WITH_LIBSTATGRAB_TRUE@am__append_13 = $(BUILD_WITH_LIBSTATGRAB_CFLAGS)
+ @BUILD_WITH_LIBSTATGRAB_TRUE@am__append_14 = $(BUILD_WITH_LIBSTATGRAB_LDFLAGS)
+ @BUILD_WITH_OWN_LIBOCONFIG_TRUE@am__append_15 = $(LIBLTDL) liboconfig/liboconfig.la
+-@BUILD_WITH_OWN_LIBOCONFIG_TRUE@am__append_16 = $(LIBLTDL) liboconfig/liboconfig.la
++@BUILD_WITH_OWN_LIBOCONFIG_TRUE@am__append_16 = liboconfig/liboconfig.la
+ @BUILD_WITH_OWN_LIBOCONFIG_FALSE@am__append_17 = -loconfig
+ @BUILD_WITH_LIBSOCKET_TRUE@am__append_18 = -lsocket
+ @BUILD_AIX_TRUE@am__append_19 = -lm
index ce1daa473fa4bb1b83ba2abea10d0eecbe500102..fae96d011d245d54dffb68e717e3815e27f90d95 100644 (file)
@@ -17,7 +17,7 @@
        /* consolidation_functions = */ NULL,
        /* consolidation_functions_num = */ 0
  };
-@@ -1027,6 +1030,14 @@ static int rrd_config (const char *key,
+@@ -1027,6 +1030,14 @@ static int rrd_config (const char *key, 
  
                free (value_copy);
        }