projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
bfeb961
)
add support for marking specific kernel module packages as potentially being required...
author
Felix Fietkau
<nbd@openwrt.org>
Fri, 26 Feb 2010 22:45:54 +0000
(22:45 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Fri, 26 Feb 2010 22:45:54 +0000
(22:45 +0000)
SVN-Revision: 19878
include/kernel.mk
patch
|
blob
|
history
diff --git
a/include/kernel.mk
b/include/kernel.mk
index 480b9682ce3c8a5066a4bafc94197860daa274df..1ca2312824a109bf415203e5a3cbb880eb58093a 100644
(file)
--- a/
include/kernel.mk
+++ b/
include/kernel.mk
@@
-70,6
+70,9
@@
define ModuleAutoLoad
add_module() { \
mkdir -p $(2)/etc/modules.d; \
( \
+ [ "$$$$$$$$3" = "1" ] && { \
+ echo '# May be required for rootfs' ; \
+ } ; \
for mod in $$$$$$$$2; do \
getvar mod; \
done \
@@
-154,7
+157,7
@@
$(call KernelPackage/$(1)/config)
endef
define AutoLoad
- add_module $(1) "$(2)";
+ add_module $(1) "$(2)"
$(3)
;
endef
ifdef DUMP