openwrt-keyring: fix missing 24.10 usign key by installing it
authorKuan-Yi Li <kyli@abysm.org>
Sat, 2 Nov 2024 20:11:36 +0000 (04:11 +0800)
committerPetr Štetiar <ynezz@true.cz>
Mon, 4 Nov 2024 09:23:40 +0000 (09:23 +0000)
@KA2107 reported that opkg is not able to verify the artifact signatures
produced by buildbot using the usign 24.10 release keys. So lets fix it
by actually adding the 24.10 usign key with d310c6f2833e97f7 fingerprint
into the openwrt-keyring package.

Fixes: #16850
Reported-by: @KA2107
Fixes: a535cfc09e1c ("openwrt-keyring: add OpenWrt 24.10 release build usign key")
References: 2d03f27f0f07 ("openwrt-keyring: make opkg use 22.03 usign key")
Signed-off-by: Kuan-Yi Li <kyli@abysm.org>
Signed-off-by: Petr Štetiar <ynezz@true.cz> [commit description]
package/system/openwrt-keyring/Makefile

index 029463817b85ddeebd8e694cbf802b6be042a4b7..6c2fa3d108b6da271bfd8daea39db62415b8a792 100644 (file)
@@ -3,7 +3,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openwrt-keyring
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/keyring.git
@@ -38,8 +38,8 @@ endef
 else
 define Package/openwrt-keyring/install
        $(INSTALL_DIR) $(1)/etc/opkg/keys/
-       # Public usign key for unattended snapshot builds
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/usign/b5043e70f9a75cde $(1)/etc/opkg/keys/
+       # Public usign key for 24.10 release builds
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/usign/d310c6f2833e97f7 $(1)/etc/opkg/keys/
 endef
 endif