v1 : do not install omshell static librairies in dhcp package
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 24 Feb 2012 10:26:32 +0000 (10:26 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 24 Feb 2012 10:26:32 +0000 (10:26 +0000)
There is no need to install any static library on the target, unless one installs a linker (and a compiler) as well, and this is certainly not a common case.
The dhcp-server package installs two of them in /usr/local/lib - along with omshell. The erroneous lines were added as part of r10146 when the Makefile
was modified to install omshell, but the static libraries are never needed to run omshell on the target.

Signed-off-by: Emmanuel Deloget <logout@free.fr>
SVN-Revision: 30707

net/dhcp/Makefile

index 374ec6fc1febccb3bacf8249fb6b660e6ac7494a..df90fdf2ae958f278a4b1dbe7c79bb0a51cb7be5 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dhcp
 PKG_VERSION:=3.1.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.isc.org/isc/dhcp/
@@ -69,7 +69,6 @@ define Package/dhcp-server/install
        $(INSTALL_DIR) $(1)/usr/local/lib
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dhcpd $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/omshell $(1)/usr/bin/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/local/lib/*.a $(1)/usr/local/lib
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dhcpd.init $(1)/etc/init.d/dhcpd
 endef