imagebuilder: also remove vmlinuz initramfs image files
authorChristian Marangi <ansuelsmth@gmail.com>
Tue, 22 Oct 2024 11:53:51 +0000 (13:53 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 22 Oct 2024 11:53:51 +0000 (13:53 +0200)
Also remove vmlinuz-initramfs files from final imagebuilder image as
these file are not needed.

Fixes: c85348d9abf4 ("imagebuilder: remove initramfs image files")
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
target/imagebuilder/Makefile

index 7127df5ebcd5d4ed510cfe007acff516fcaa8871..ecc791b8e9b3473d1666f5ef2dc25b22cf8bbc48 100644 (file)
@@ -114,6 +114,7 @@ endif
        rm -f $(IB_KDIR)/vmlinux.debug
        # remove any file for initramfs and Per Device Rootfs initramfs files
        rm -f $(IB_KDIR)/vmlinux-initramfs*
+       rm -f $(IB_KDIR)/vmlinuz-initramfs*
        rm -f $(IB_KDIR)/Image-initramfs*
        if [ -x $(LINUX_DIR)/scripts/dtc/dtc ]; then \
                $(INSTALL_DIR) $(IB_LDIR)/scripts/dtc; \