projects
/
openwrt
/
svn-archive
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
2adec4c
)
libs/fftw3: install headers and libraries into staging_dir
author
Andy Boyett
<agb@openwrt.org>
Tue, 6 Jan 2009 05:32:19 +0000
(
05:32
+0000)
committer
Andy Boyett
<agb@openwrt.org>
Tue, 6 Jan 2009 05:32:19 +0000
(
05:32
+0000)
SVN-Revision: 13879
libs/fftw3/Makefile
patch
|
blob
|
history
diff --git
a/libs/fftw3/Makefile
b/libs/fftw3/Makefile
index ff58a30f9b4ae016085ca5f7a14a9c7fba9de730..734f8a75b7a8da15a691f21a964b12bfb3e90b8e 100644
(file)
--- a/
libs/fftw3/Makefile
+++ b/
libs/fftw3/Makefile
@@
-54,6
+54,13
@@
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
endef
+define Build/InstallDev
+ mkdir -p $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/fftw3.h $(1)/usr/include
+ mkdir -p $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfftw3*.{a,so,la} $(1)/usr/lib
+endef
+
define Package/fftw3/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libfftw3.so* $(1)/usr/lib/