ncurses: Fix path in ncursesw.pc
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 27 Jul 2024 17:29:04 +0000 (19:29 +0200)
committerRobert Marko <robimarko@gmail.com>
Sun, 28 Jul 2024 17:30:35 +0000 (19:30 +0200)
The file contains the the /usr/lib path from the toolchain directory and
not from the target directory. The /usr/lib directory for the toolchain
is empty and the shared library is not in the specified paths. On RISCV
the linker of util-linux was finding the libncursesw.so in my host
system, tried to link against it and failed. Fix the .pc file.

Fixes: #15942
Co-authored-by: Thomas Weißschuh <thomas@t-8ch.de>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Link: https://github.com/openwrt/openwrt/pull/16018
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/libs/ncurses/Makefile

index 0958051533278afd4ffa4c84d2dd6fe9f6c43055..0fcc3888401478d6c7000cfa1e5de865487084ab 100644 (file)
@@ -181,6 +181,8 @@ define Build/InstallDev
        $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' -e 's/$$$$INCS //g' \
                $(2)/bin/ncursesw6-config
        ln -sf $(STAGING_DIR)/host/bin/ncursesw6-config $(1)/usr/bin/ncursesw6-config
+       $(SED) 's,$(TOOLCHAIN_DIR),$(STAGING_DIR),g' \
+               $(1)/usr/lib/pkgconfig/ncursesw.pc
 endef
 
 define Host/Compile