build: fix `which` detection on Fedora & MacOS
authorPaul Spooren <mail@aparcar.org>
Sat, 2 Oct 2021 01:56:27 +0000 (15:56 -1000)
committerPaul Spooren <mail@aparcar.org>
Sat, 9 Oct 2021 02:32:23 +0000 (16:32 -1000)
Fix Fedora 34/35 issue where 'which' detection of 'which' wasn't working
because Fedora use alias and proc

Fixup of fca5ad55d2 prereq-build: fix `which` detection on Fedora

Reported-by: Jani Partanen <rtfm@iki.fi>
Suggest-by: Etienne Champetier <champetier.etienne@gmail.com>
Tested-by: Georgi Valkov <gvalkov@abv.bg>
Signed-off-by: Paul Spooren <mail@aparcar.org>
(cherry picked from commit 0d1ebf0d6d20f0439ab45b293f9daa7662c44ba6)

include/prereq-build.mk

index 538aee58fed23142656102f6ec0f4c4aa9ffa38f..623881c93f1721353f85aef9081cb6aadcae664c 100644 (file)
@@ -182,7 +182,9 @@ $(eval $(call SetupHostCommand,rsync,Please install 'rsync', \
        rsync --version </dev/null))
 
 $(eval $(call SetupHostCommand,which,Please install 'which', \
-       which which | grep which))
+       /usr/bin/which which, \
+       /bin/which which, \
+       which which))
 
 $(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
        mkdir -p $(dir $@)