compat-wireless: Select minstrel_ht as default rc algo
authorHelmut Schaa <helmut.schaa@googlemail.com>
Sat, 18 Sep 2010 09:56:06 +0000 (02:56 -0700)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Sat, 18 Sep 2010 21:40:18 +0000 (14:40 -0700)
Wireless-testing is using minstrel_ht already as default rc algorithm.
Do the same im compat-wireless. Setting CONFIG_MAC80211_RC_DEFAULT
manually is needed in compat-wireless since it doesn't have the Kconfig
magic to automagically select minstrel_ht if it is compiled in.

Signed-off-by: Helmut Schaa <helmut.schaa@googlemail.com>
config.mk

index b61c318620ba25389452430f1d2244616f84065b..a021172f3332be44626d4a3e40469b46e5cb8402 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -124,12 +124,12 @@ CONFIG_MAC80211=m
 # CONFIG_MAC80211_DRIVER_API_TRACER=y
 
 # choose between pid and minstrel as default rate control algorithm
-CONFIG_MAC80211_RC_DEFAULT=minstrel
+CONFIG_MAC80211_RC_DEFAULT=minstrel_ht
 CONFIG_MAC80211_RC_DEFAULT_MINSTREL=y
 # CONFIG_MAC80211_RC_DEFAULT_PID=y
 # This is the one used by our compat-wireless net/mac80211/rate.c
 # in case you have and old kernel which is overriding this to pid.
-CONFIG_COMPAT_MAC80211_RC_DEFAULT=minstrel
+CONFIG_COMPAT_MAC80211_RC_DEFAULT=minstrel_ht
 CONFIG_MAC80211_RC_PID=y
 CONFIG_MAC80211_RC_MINSTREL=y
 CONFIG_MAC80211_RC_MINSTREL_HT=y