projects
/
openwrt
/
staging
/
dangole.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
2fca8aa
)
imx6: use DTS_DIR at image build code
author
Adrià Llaudet
<adria.llaudet@gmail.com>
Thu, 8 Feb 2018 11:02:24 +0000
(12:02 +0100)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 10 Feb 2018 20:02:53 +0000
(21:02 +0100)
Use "$(DTS_DIR)", defined at include/image.mk, instead of
"$(LINUX_DIR)/arch/$(LINUX_KARCH)/boot/dts" in order to generalize and
allow a better Device/* device-tree parameterization (i.e. DEVICE_DTS_DIR
and DTS_DIR).
Signed-off-by: Adrià Llaudet <adria.llaudet@gmail.com>
target/linux/imx6/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/imx6/image/Makefile
b/target/linux/imx6/image/Makefile
index 7f35c56b794ccb72a484a39562eaa326a970681e..cef08f227eb90c5f25bf6973cf3bd7a30c1f04df 100644
(file)
--- a/
target/linux/imx6/image/Makefile
+++ b/
target/linux/imx6/image/Makefile
@@
-22,7
+22,7
@@
define Build/boot-overlay
$(foreach dts,$(DEVICE_DTS), \
$(CP) \
- $(
LINUX_DIR)/arch/$(ARCH)/boot/dts
/$(dts).dtb \
+ $(
DTS_DIR)
/$(dts).dtb \
$@.boot/$(IMG_PREFIX)-$(dts).dtb; \
ln -sf \
$(IMG_PREFIX)-$(dts).dtb \