projects
/
openwrt
/
staging
/
ynezz.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b0bf5fd
)
install static libraries from uclibc to the rootfs staging dir
author
Felix Fietkau
<nbd@openwrt.org>
Sat, 8 Aug 2009 02:24:45 +0000
(
02:24
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sat, 8 Aug 2009 02:24:45 +0000
(
02:24
+0000)
SVN-Revision: 17169
package/base-files/Makefile
patch
|
blob
|
history
diff --git
a/package/base-files/Makefile
b/package/base-files/Makefile
index 2c88458af4c1de26b30afde37ec243c2757c5a78..6901829f29290604942631537d1ca83667a5cad9 100644
(file)
--- a/
package/base-files/Makefile
+++ b/
package/base-files/Makefile
@@
-247,6
+247,10
@@
define Package/libc/install
$(call Package/$(LIBC)/install,$1)
endef
+define Package/libc/install_lib
+ $(CP) $(filter-out %/libdl_pic.a,$(wildcard $(TOOLCHAIN_DIR)/usr/lib/lib*.a)) $(1)/lib/
+endef
+
define Package/libpthread/install
$(INSTALL_DIR) $(1)/lib
$(CP) $(TOOLCHAIN_DIR)/lib/libpthread.so.* $(1)/lib/