#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
include $(TOPDIR)/rules.mk
PKG_NAME:=dibbler
-PKG_VERSION:=0.6.0-RC1
+PKG_VERSION:=0.6.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.gz
-PKG_SOURCE_URL:=@SF/dibbler
-PKG_MD5SUM:=d279efa2b43279f17f6f51cae083d458
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=220e68795ab0375cb3bc1f40c47e0bb2
include $(INCLUDE_DIR)/package.mk
server client relay
endef
-define Package/dibbler-client/install
+define Package/dibbler-client/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dibbler-client $(1)/usr/sbin/
endef
-define Package/dibbler-relay/install
+define Package/dibbler-relay/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dibbler-relay $(1)/usr/sbin/
endef
-define Package/dibbler-server/install
+define Package/dibbler-server/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dibbler-server $(1)/usr/sbin/
endef
-diff -ruN dibbler-0.6.0-RC1-old/Makefile dibbler-0.6.0-RC1-new/Makefile
---- dibbler-0.6.0-RC1-old/Makefile 2007-01-30 21:34:24.000000000 +0100
-+++ dibbler-0.6.0-RC1-new/Makefile 2007-09-01 04:55:38.000000000 +0200
-@@ -32,7 +32,7 @@
+Index: dibbler-0.6.1/Makefile
+===================================================================
+--- dibbler-0.6.1.orig/Makefile 2008-03-12 13:27:35.000000000 +0100
++++ dibbler-0.6.1/Makefile 2008-03-12 13:27:36.000000000 +0100
+@@ -39,7 +39,7 @@
$(CLIENTBIN): libposlib includes commonlibs clntlibs $(MISC)/DHCPClient.o $(CLIENT)
@echo "[LINK ] $(SUBDIR)/$@ ($(LINKPRINT))"
-L$(MISC) -lMisc \
-L$(ADDRMGR) -lAddrMgr \
-L$(CLNTADDRMGR) -lClntAddrMgr \
-@@ -50,7 +50,8 @@
+@@ -57,7 +57,8 @@
-L$(MESSAGES) -lMsg \
-lClntOptions -lOptions -lLowLevel \
-L$(MISC) -lMisc \
ifndef MOD_CLNT_DISABLE_DNSUPDATE
CLNTPOSLIB=-lposlib
-@@ -60,7 +61,7 @@
+@@ -67,7 +68,7 @@
$(SERVERBIN): libposlib includes commonlibs srvlibs $(MISC)/DHCPServer.o $(SERVER)
@echo "[LINK ] $(SUBDIR)/$@ ($(LINKPRINT))"
-L$(SRVADDRMGR) -lSrvAddrMgr \
-L$(ADDRMGR) -lAddrMgr \
-L$(LOWLEVEL) \
-@@ -81,7 +82,8 @@
+@@ -88,7 +89,8 @@
-L$(MISC) -lMisc \
-L$(LOWLEVEL) -lLowLevel \
-L$(IFACEMGR) -lIfaceMgr \
ifndef MOD_SRV_DISABLE_DNSUPDATE
SRVPOSLIB=-lposlib
-@@ -91,7 +93,7 @@
+@@ -98,7 +100,7 @@
$(RELAYBIN): poslib-configure includes commonlibs relaylibs $(MISC)/DHCPRelay.o $(RELAY)
@echo "[LINK ] $(SUBDIR)/$@ ($(LINKPRINT))"
-L$(RELTRANSMGR) -lRelTransMgr \
-L$(RELCFGMGR) -lRelCfgMgr \
-L$(RELIFACEMGR) -lRelIfaceMgr \
-@@ -104,7 +106,8 @@
+@@ -111,7 +113,8 @@
-L$(MESSAGES) -lMsg \
-L$(MISC) -lMisc \
-L$(OPTIONS) -lOptions \
objs: includes
@for dir in $(COMMONSUBDIRS); do \
-diff -ruN dibbler-0.6.0-RC1-old/Makefile.inc dibbler-0.6.0-RC1-new/Makefile.inc
---- dibbler-0.6.0-RC1-old/Makefile.inc 2007-02-03 19:02:11.000000000 +0100
-+++ dibbler-0.6.0-RC1-new/Makefile.inc 2007-09-01 04:56:44.000000000 +0200
+Index: dibbler-0.6.1/Makefile.inc
+===================================================================
+--- dibbler-0.6.1.orig/Makefile.inc 2008-03-12 13:27:35.000000000 +0100
++++ dibbler-0.6.1/Makefile.inc 2008-03-12 13:27:36.000000000 +0100
@@ -1,5 +1,6 @@
# === used tools ===
- CXX = g++
-+CXXLD = $(CXX)
- CC = gcc
+ CXX ?= g++
++CXXLD ?= $(CXX)
+ CC ?= gcc
FLEX = flex
BISONPP = $(PREFIX)/bison++/bison++ -S $(PREFIX)/bison++/bison.cc -H $(PREFIX)/bison++/bison.h
-Index: dibbler-0.6.0/Misc/Makefile
+Index: dibbler-0.6.1/Misc/Makefile
===================================================================
---- dibbler-0.6.0.orig/Misc/Makefile 2007-07-31 12:08:57.168388403 +0200
-+++ dibbler-0.6.0/Misc/Makefile 2007-07-31 12:09:14.901398951 +0200
+--- dibbler-0.6.1.orig/Misc/Makefile 2008-03-12 13:27:35.000000000 +0100
++++ dibbler-0.6.1/Misc/Makefile 2008-03-12 13:27:36.000000000 +0100
@@ -26,9 +26,9 @@
$(CC) $(COPTS) -std=c99 -c sha512.c
+++ /dev/null
-Index: dibbler-0.6.0-RC1/Port-linux/iproute.c
-===================================================================
---- dibbler-0.6.0-RC1.orig/Port-linux/iproute.c 2007-10-21 09:25:04.698543780 +0200
-+++ dibbler-0.6.0-RC1/Port-linux/iproute.c 2007-10-21 09:25:30.572018227 +0200
-@@ -28,7 +28,6 @@
- #include <netinet/ip.h>
- #include <arpa/inet.h>
- #include <linux/in_route.h>
--#include <linux/ip_mp_alg.h>
-
- #include "rt_names.h"
- #include "utils.h"
-@@ -95,14 +94,6 @@
- inet_prefix msrc;
- } filter;
-
--static char *mp_alg_names[IP_MP_ALG_MAX+1] = {
-- [IP_MP_ALG_NONE] = "none",
-- [IP_MP_ALG_RR] = "rr",
-- [IP_MP_ALG_DRR] = "drr",
-- [IP_MP_ALG_RANDOM] = "random",
-- [IP_MP_ALG_WRANDOM] = "wrandom"
--};
--
- static int flush_update(void)
- {
- if (rtnl_send(&rth, filter.flushb, filter.flushp) < 0) {
-@@ -335,14 +326,6 @@
- fprintf(fp, "tos %s ", rtnl_dsfield_n2a(r->rtm_tos, b1, sizeof(b1)));
- }
-
-- if (tb[RTA_MP_ALGO]) {
-- __u32 mp_alg = *(__u32*) RTA_DATA(tb[RTA_MP_ALGO]);
-- if (mp_alg > IP_MP_ALG_NONE) {
-- fprintf(fp, "mpath %s ",
-- mp_alg < IP_MP_ALG_MAX ? mp_alg_names[mp_alg] : "unknown");
-- }
-- }
--
- if (tb[RTA_GATEWAY] && filter.rvia.bitlen != host_len) {
- fprintf(fp, "via %s ",
- format_host(r->rtm_family,
-@@ -846,18 +829,6 @@
- strcmp(*argv, "oif") == 0) {
- NEXT_ARG();
- d = *argv;
-- } else if (strcmp(*argv, "mpath") == 0 ||
-- strcmp(*argv, "mp") == 0) {
-- int i;
-- __u32 mp_alg = IP_MP_ALG_NONE;
--
-- NEXT_ARG();
-- for (i = 1; i < ARRAY_SIZE(mp_alg_names); i++)
-- if (strcmp(*argv, mp_alg_names[i]) == 0)
-- mp_alg = i;
-- if (mp_alg == IP_MP_ALG_NONE)
-- invarg("\"mpath\" value is invalid\n", *argv);
-- addattr_l(&req.n, sizeof(req), RTA_MP_ALGO, &mp_alg, sizeof(mp_alg));
- } else {
- int type;
- inet_prefix dst;