Add quagga isisd, closes #735
authorFlorian Fainelli <florian@openwrt.org>
Mon, 28 Aug 2006 20:02:36 +0000 (20:02 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 28 Aug 2006 20:02:36 +0000 (20:02 +0000)
SVN-Revision: 4694

openwrt/package/quagga/Config.in
openwrt/package/quagga/Makefile
openwrt/package/quagga/files/quagga.init
openwrt/package/quagga/ipkg/quagga-isisd.control [new file with mode: 0644]
openwrt/package/quagga/ipkg/quagga.control

index 7e893e2053a293c0e339bdc2810e7157a0329cb8..ea6bbd73bcd8605a8d32c332a762f468ca1964a7 100644 (file)
@@ -52,6 +52,14 @@ config BR2_PACKAGE_QUAGGA_RIPNGD
        help
          A RIPNG (IPv6) routing engine for use with Quagga routing software.
 
+config BR2_PACKAGE_QUAGGA_ISISD
+        depends BR2_PACKAGE_QUAGGA
+        prompt"...-isisd - IS-IS routing engine"
+        tristate
+        default m if CONFIG_DEVEL
+        help
+          An IS-IS routing engine for use with Quagga routing software.
+
 config BR2_PACKAGE_QUAGGA_VTYSH
        depends BR2_PACKAGE_QUAGGA
        select BR2_PACKAGE_LIBREADLINE
index 16acedcea77547254060b02d604eb3bbf3a74777..5a73e576891b16392f74d44b064545b213331139 100644 (file)
@@ -25,6 +25,7 @@ $(eval $(call PKG_template,QUAGGA_OSPFD,quagga-ospfd,$(PKG_VERSION)-$(PKG_RELEAS
 $(eval $(call PKG_template,QUAGGA_OSPF6D,quagga-ospf6d,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,QUAGGA_RIPD,quagga-ripd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,QUAGGA_RIPNGD,quagga-ripngd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,QUAGGA_ISISD,quagga-isisd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,QUAGGA_VTYSH,quagga-vtysh,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(PKG_BUILD_DIR)/.configured:
@@ -60,6 +61,8 @@ $(PKG_BUILD_DIR)/.configured:
                --enable-vtysh \
                --enable-user=quagga \
                --enable-group=quagga \
+               --enable-multipath=8 \
+               --enable-isisd \
        );
        touch $@
 
@@ -116,6 +119,12 @@ $(IPKG_QUAGGA_RIPNGD):
        $(RSTRIP) $(IDIR_QUAGGA_RIPNGD)
        $(IPKG_BUILD) $(IDIR_QUAGGA_RIPNGD) $(PACKAGE_DIR)
 
+$(IPKG_QUAGGA_ISISD):
+       install -d -m0755 $(IDIR_QUAGGA_ISISD)/usr/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/isisd $(IDIR_QUAGGA_ISISD)/usr/sbin/
+       $(RSTRIP) $(IDIR_QUAGGA_ISISD)
+       $(IPKG_BUILD) $(IDIR_QUAGGA_ISISD) $(PACKAGE_DIR)
+
 $(IPKG_QUAGGA_VTYSH):
        install -d -m0755 $(IDIR_QUAGGA_VTYSH)/usr/bin
        cp -fpR $(PKG_INSTALL_DIR)/usr/bin/vtysh $(IDIR_QUAGGA_VTYSH)/usr/bin/
index 01f8d7137d13b11a107bbd876539d8f5a98a8279..1c6f3783bf1b4da7b225010730f40fa75b8c5abd 100644 (file)
@@ -27,7 +27,7 @@ ARG_DAEMONS=$*
 BINDIR=/usr/sbin
 CONFDIR=/etc/quagga
 STATEDIR=/var/run/quagga
-DAEMONS="zebra ripd ripngd ospfd ospf6d bgpd"
+DAEMONS="zebra ripd ripngd ospfd ospf6d bgpd isisd"
 DAEMON_FLAGS=-d
 WATCHQUAGGA_FLAGS="-d -z -T 60 -R"
 WATCHQUAGGA_CMD="$0 watchrestart"
diff --git a/openwrt/package/quagga/ipkg/quagga-isisd.control b/openwrt/package/quagga/ipkg/quagga-isisd.control
new file mode 100644 (file)
index 0000000..23b1da5
--- /dev/null
@@ -0,0 +1,6 @@
+Package: quagga-isisd
+Priority: optional
+Section: net
+Depends: quagga
+Description: An IS-IS routing engine for use with Quagga
+ routing software
index 303f299e81255284888f212a6a9caa5821727bf8..e02fc62aaedc5688bd5cd6df15634d0da553c40c 100644 (file)
@@ -3,4 +3,5 @@ Priority: optional
 Section: net
 Description: A routing software package that provides TCP/IP
  based routing services with routing protocols support such
- as RIPv1, RIPv2, RIPng, OSPFv2, OSPFv3, BGP-4, and BGP-4+.
+ as RIPv1, RIPv2, RIPng, OSPFv2, OSPFv3, BGP-4, and BGP-4+
+ IS-IS.