-diff -ruN gtkhtml-3.29.1/components/Makefile.am gtkhtml-3.29.1.mod/components/Makefile.am
---- gtkhtml-3.29.1/components/Makefile.am 2009-10-23 12:25:35.000000000 +0200
-+++ gtkhtml-3.29.1.mod/components/Makefile.am 2009-10-30 18:33:25.000000000 +0100
+--- a/components/Makefile.am
++++ b/components/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = editor
+SUBDIRS =
-include $(top_srcdir)/git.mk
-diff -ruN gtkhtml-3.29.1/components/Makefile.in gtkhtml-3.29.1.mod/components/Makefile.in
---- gtkhtml-3.29.1/components/Makefile.in 2009-10-26 09:22:21.000000000 +0100
-+++ gtkhtml-3.29.1.mod/components/Makefile.in 2009-10-30 18:32:41.000000000 +0100
-@@ -265,7 +265,7 @@
+--- a/components/Makefile.in
++++ b/components/Makefile.in
+@@ -265,7 +265,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
all: all-recursive
.SUFFIXES:
-diff -ruN gtkhtml-3.29.1/configure gtkhtml-3.29.1.mod/configure
---- gtkhtml-3.29.1/configure 2009-10-26 09:22:19.000000000 +0100
-+++ gtkhtml-3.29.1.mod/configure 2009-10-30 18:39:32.000000000 +0100
-@@ -21911,7 +21911,7 @@
+--- a/configure
++++ b/configure
+@@ -21911,7 +21911,7 @@ fi
pkg_failed=no
{ $as_echo "$as_me:$LINENO: checking for GTKHTML" >&5
+--- a/configure.ac
++++ b/configure.ac
+@@ -136,7 +136,7 @@ PKG_CHECK_MODULES(GTHREAD, $GTHREAD_MODU
+ AC_SUBST(GTHREAD_CFLAGS)
+ AC_SUBST(GTHREAD_LIBS)
+
+-GTKHTML_MODULES="gtk+-2.0 >= gtk_minimum_version enchant gconf-2.0 iso-codes"
++GTKHTML_MODULES="gtk+-2.0 >= gtk_minimum_version gconf-2.0"
+ PKG_CHECK_MODULES(GTKHTML, $GTKHTML_MODULES)
+ AC_SUBST(GTKHTML_CFLAGS)
+ AC_SUBST(GTKHTML_LIBS)
---- gtkhtml-3.29.1/gtkhtml/gtkhtml.c 2009-10-26 07:49:58.000000000 +0100
-+++ gtkhtml-3.29.1.mod/gtkhtml/gtkhtml.c 2009-11-22 12:46:18.000000000 +0100
-@@ -128,8 +128,8 @@
+--- a/gtkhtml/gtkhtml.c
++++ b/gtkhtml/gtkhtml.c
+@@ -128,8 +128,8 @@ struct _ClipboardContents {
static GtkLayoutClass *parent_class = NULL;
enum {
TITLE_CHANGED,
-@@ -791,7 +791,7 @@
+@@ -791,7 +791,7 @@ destroy (GtkObject *object)
}
if (html->priv->notify_monospace_font_id) {
html->priv->notify_monospace_font_id = 0;
}
-@@ -832,61 +832,64 @@
+@@ -832,61 +832,64 @@ gtk_html_get_top_html (GtkHTML *html)
static cairo_font_options_t *
get_font_options (void)
{
return font_options;
}
-@@ -913,36 +916,36 @@
+@@ -913,36 +916,36 @@ gtk_html_set_fonts (GtkHTML *html, HTMLP
font_var_points = !pango_font_description_get_size_is_absolute (style->font_desc);
gtk_widget_style_get (GTK_WIDGET (top_level), "fixed_font_name", &fixed_name, NULL);
if (!fixed_name) {
fixed_family = "Monospace";
-@@ -2365,22 +2368,22 @@
+@@ -2365,22 +2368,22 @@ setup_class_properties (GtkHTML *html)
if (!klass->properties) {
klass->properties = gtk_html_class_properties_new (GTK_WIDGET (html));
}
}
-@@ -2748,41 +2751,41 @@
+@@ -2748,41 +2751,41 @@ drag_motion (GtkWidget *widget, GdkDragC
/* dnd end */
static void
gtk_html_direction_changed (GtkWidget *widget, GtkTextDirection previous_dir)
-@@ -2823,7 +2826,7 @@
+@@ -2823,7 +2826,7 @@ gtk_html_class_init (GtkHTMLClass *klass
GtkLayoutClass *layout_class;
GtkContainerClass *container_class;
gchar *filename;
html_class = (GtkHTMLClass *) klass;
#ifdef USE_PROPS
-@@ -3176,18 +3179,18 @@
+@@ -3176,18 +3179,18 @@ gtk_html_class_init (GtkHTMLClass *klass
gtk_rc_parse (filename);
g_free (filename);
html_class->emacs_bindings = gtk_binding_set_find ("gtkhtml-bindings-emacs");
}
static void
-@@ -3195,8 +3198,8 @@
+@@ -3195,8 +3198,8 @@ init_properties_widget (GtkHTML *html)
{
setup_class_properties (html);
}
-@@ -3478,9 +3481,9 @@
+@@ -3478,9 +3481,9 @@ gtk_html_init (GtkHTML* html)
g_signal_connect (G_OBJECT (html->priv->im_context), "delete_surrounding",
G_CALLBACK (gtk_html_im_delete_surrounding_cb), html);
gtk_html_construct (html);
}
-@@ -3579,7 +3582,7 @@
+@@ -3579,7 +3582,7 @@ gtk_html_construct (GtkHTML *html)
g_signal_connect (G_OBJECT (html->engine), "object_requested",
G_CALLBACK (html_engine_object_requested_cb), html);
}
\f
-@@ -6044,7 +6047,7 @@
+@@ -6044,7 +6047,7 @@ gtk_html_edit_make_cursor_visible (GtkHT
gboolean
gtk_html_build_with_gconf (void)
{
}
static void
---- gtkhtml-3.29.1/gtkhtml/gtkhtml-properties.h 2009-06-26 13:14:48.000000000 +0200
-+++ gtkhtml-3.29.1.mod/gtkhtml/gtkhtml-properties.h 2009-11-22 12:20:54.000000000 +0100
+--- a/gtkhtml/gtkhtml-properties.h
++++ b/gtkhtml/gtkhtml-properties.h
@@ -27,7 +27,7 @@
#define GTK_HTML_GNOME_CONFIG_PREFIX "/gtkhtml/Settings/"
#include "gtkhtml-types.h"
#include "gtkhtml.h"
-@@ -51,11 +51,11 @@
+@@ -51,11 +51,11 @@ GtkHTMLClassProperties * gtk_html_class_
void gtk_html_class_properties_destroy (GtkHTMLClassProperties *p);
void gtk_html_class_properties_copy (GtkHTMLClassProperties *p1,
GtkHTMLClassProperties *p2);
/* enum types */
---- gtkhtml-3.29.1/gtkhtml/gtkhtml-properties.c 2009-10-23 12:26:15.000000000 +0200
-+++ gtkhtml-3.29.1.mod/gtkhtml/gtkhtml-properties.c 2009-12-11 00:57:25.000000000 +0100
-@@ -102,20 +102,20 @@
+--- a/gtkhtml/gtkhtml-properties.c
++++ b/gtkhtml/gtkhtml-properties.c
+@@ -102,20 +102,20 @@ gtk_html_class_properties_destroy (GtkHT
g_free (p);
}