projects
/
openwrt
/
staging
/
luka.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
aea8213
)
Fix missing dependency in solos-pci module
author
Florian Fainelli
<florian@openwrt.org>
Sun, 19 Sep 2010 11:18:00 +0000
(11:18 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Sun, 19 Sep 2010 11:18:00 +0000
(11:18 +0000)
Modinfo for solos-pci tells us that it has a dependency on "atm", but this isn't
captured in the Makefile.
Signed-off-by: Philip A. Prindeville <philipp_subx@redfish-solutions.com>
SVN-Revision: 23086
package/kernel/modules/netdevices.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/netdevices.mk
b/package/kernel/modules/netdevices.mk
index aaee3acce8a61b2e4f091682adf8e5dc6b7ba5f3..61fccf4fd7d2e95696a29221dbb1d50c9c851d2d 100644
(file)
--- a/
package/kernel/modules/netdevices.mk
+++ b/
package/kernel/modules/netdevices.mk
@@
-489,7
+489,7
@@
$(eval $(call KernelPackage,tulip))
define KernelPackage/solos-pci
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Solos ADSL2+ multiport modem
- DEPENDS:=@TARGET_x86
+ DEPENDS:=@TARGET_x86
+kmod-atm
KCONFIG:=CONFIG_ATM_SOLOS
FILES:=$(LINUX_DIR)/drivers/atm/solos-pci.ko
AUTOLOAD:=$(call AutoLoad,50,solos-pci)