ASoC: Intel: common: add table for HDA-based platforms
authorPierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>
Wed, 22 Aug 2018 20:24:58 +0000 (15:24 -0500)
committerMark Brown <broonie@kernel.org>
Tue, 28 Aug 2018 19:18:07 +0000 (20:18 +0100)
Expose a table containing machine driver information for HDAudio-based
platforms handled by ASoC on Intel hardware.

We only set constant values that are valid across multiple
platforms. The firmware name used by the DSP will be set dynamically
for each platform.

The table is made of a single entry for now, if we need more
complicated set-up where HDAudio is mixed with ACPI-enumerated devices
(I2C, SoundWire) then we'd expect the differentiation to be handled
through information provided by the BIOS (as done for KBL
Chromebooks).

Signed-off-by: Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>
Signed-off-by: Mark Brown <broonie@kernel.org>
include/sound/soc-acpi-intel-match.h
sound/soc/intel/common/Makefile
sound/soc/intel/common/soc-acpi-intel-hda-match.c [new file with mode: 0644]

index bb1d24b703fb05a09b751c1fa7d36177553250b8..f48f59e5b7b02bc394f184e9e39ab0f66503c8a8 100644 (file)
@@ -25,4 +25,10 @@ extern struct snd_soc_acpi_mach snd_soc_acpi_intel_bxt_machines[];
 extern struct snd_soc_acpi_mach snd_soc_acpi_intel_glk_machines[];
 extern struct snd_soc_acpi_mach snd_soc_acpi_intel_cnl_machines[];
 
+/*
+ * generic table used for HDA codec-based platforms, possibly with
+ * additional ACPI-enumerated codecs
+ */
+extern struct snd_soc_acpi_mach snd_soc_acpi_intel_hda_machines[];
+
 #endif
index 915a34cdc8acbb2b8f281c377a4a45394aa6ed26..c1f50a079d34aad252b84fe6830e01fb987bb5d4 100644 (file)
@@ -7,7 +7,8 @@ snd-soc-acpi-intel-match-objs := soc-acpi-intel-byt-match.o soc-acpi-intel-cht-m
        soc-acpi-intel-hsw-bdw-match.o \
        soc-acpi-intel-skl-match.o soc-acpi-intel-kbl-match.o \
        soc-acpi-intel-bxt-match.o soc-acpi-intel-glk-match.o \
-       soc-acpi-intel-cnl-match.o
+       soc-acpi-intel-cnl-match.o \
+       soc-acpi-intel-hda-match.o
 
 obj-$(CONFIG_SND_SOC_INTEL_SST) += snd-soc-sst-dsp.o snd-soc-sst-ipc.o
 obj-$(CONFIG_SND_SOC_INTEL_SST_ACPI) += snd-soc-sst-acpi.o
diff --git a/sound/soc/intel/common/soc-acpi-intel-hda-match.c b/sound/soc/intel/common/soc-acpi-intel-hda-match.c
new file mode 100644 (file)
index 0000000..533c106
--- /dev/null
@@ -0,0 +1,40 @@
+// SPDX-License-Identifier: GPL-2.0
+// Copyright (c) 2018, Intel Corporation.
+
+/*
+ * soc-apci-intel-hda-match.c - tables and support for HDA+ACPI enumeration.
+ *
+ */
+
+#include <sound/soc-acpi.h>
+#include <sound/soc-acpi-intel-match.h>
+#include "../skylake/skl.h"
+
+static struct skl_machine_pdata hda_pdata = {
+       .use_tplg_pcm = true,
+};
+
+struct snd_soc_acpi_mach snd_soc_acpi_intel_hda_machines[] = {
+       {
+               /* .id is not used in this file */
+               .drv_name = "skl_hda_dsp_generic",
+
+               /* .fw_filename is dynamically set in skylake driver */
+
+               /* .sof_fw_filename is dynamically set in sof/intel driver */
+
+               .sof_tplg_filename = "intel/sof-hda-generic.tplg",
+
+               /*
+                * .machine_quirk and .quirk_data are not used here but
+                * can be used if we need a more complicated machine driver
+                * combining HDA+other device (e.g. DMIC).
+                */
+               .pdata = &hda_pdata,
+       },
+       {},
+};
+EXPORT_SYMBOL_GPL(snd_soc_acpi_intel_hda_machines);
+
+MODULE_LICENSE("GPL v2");
+MODULE_DESCRIPTION("Intel Common ACPI Match module");