ucode: fix host installation
authorDavid Bauer <david.bauer@uniberg.com>
Mon, 19 Aug 2024 13:25:10 +0000 (15:25 +0200)
committerDavid Bauer <mail@david-bauer.net>
Tue, 10 Sep 2024 02:31:05 +0000 (04:31 +0200)
The path for linking libucode.so was not specified for the ucode binary.
This breaks execution of ucode in the host context.

Signed-off-by: David Bauer <david.bauer@uniberg.com>
package/utils/ucode/Makefile

index aa7a28483df1264e10a248cb409362cfe0b41b98..125f32ba65a92dd41cfec8efa554e6e1250bc3d4 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ucode
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=https://github.com/jow-/ucode.git
@@ -25,16 +25,17 @@ include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/cmake.mk
 
-CMAKE_OPTIONS += -DSOVERSION=$(PKG_ABI_VERSION)
+CMAKE_OPTIONS += \
+       -DSOVERSION=$(PKG_ABI_VERSION)
+       -DCMAKE_SKIP_RPATH=FALSE \
+       -DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOSTPKG}/lib"
 
 ifeq ($(HOST_OS),Darwin)
   CMAKE_HOST_OPTIONS += \
-       -DCMAKE_SKIP_RPATH=FALSE \
-       -DCMAKE_MACOSX_RPATH=1 \
-       -DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOSTPKG}/lib"
+       -DCMAKE_MACOSX_RPATH=1
 else
   CMAKE_HOST_OPTIONS += \
-       -DSOVERSION=$(PKG_ABI_VERSION)
+       -DUSE_RPATH="${STAGING_DIR_HOSTPKG}/lib"
 endif
 
 CMAKE_HOST_OPTIONS += \