port strace to -ng.
authorNicolas Thill <nico@openwrt.org>
Sun, 2 Jul 2006 20:26:19 +0000 (20:26 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 2 Jul 2006 20:26:19 +0000 (20:26 +0000)
SVN-Revision: 4110

utils/strace/Makefile [new file with mode: 0644]

diff --git a/utils/strace/Makefile b/utils/strace/Makefile
new file mode 100644 (file)
index 0000000..02a1b51
--- /dev/null
@@ -0,0 +1,73 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=strace
+PKG_VERSION:=4.5.11
+PKG_RELEASE:=1
+PKG_MD5SUM:=28335e15c83456a3db055a0a0efcb4fe
+
+PKG_SOURCE_URL:=@SF/strace
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_CAT:=bzcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/strace
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=System call tracer
+  DESCRIPTION:=A useful diagnostic, instructional, and debugging tool. \\\
+    Allows you to track what system calls a program makes while it is \\\
+    running.
+  URL:=http://strace.sourceforge.net/
+endef
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_NLS) \
+                       $(DISABLE_LARGEFILE) \
+       );
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC)
+endef
+
+define Package/strace/install
+       install -m0755 -d $(1)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/strace $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,strace))