kbuild: create symlink to vmlinux-gdb.py in scripts_gdb target
authorMasahiro Yamada <yamada.masahiro@socionext.com>
Tue, 19 Feb 2019 09:33:05 +0000 (18:33 +0900)
committerMasahiro Yamada <yamada.masahiro@socionext.com>
Wed, 27 Feb 2019 12:40:54 +0000 (21:40 +0900)
It is weird to create gdb stuff as a side-effect of vmlinux.

Move it to a more relevant place.

Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Makefile

index d05da1b9982baa5b006165fd53da4dcc6cbd85fc..498b6c5cee0f38f022d42e541455f2024b455754 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1021,9 +1021,6 @@ cmd_link-vmlinux =                                                 \
        $(if $(ARCH_POSTLINK), $(MAKE) -f $(ARCH_POSTLINK) $@, true)
 
 vmlinux: scripts/link-vmlinux.sh autoksyms_recursive $(vmlinux-deps) FORCE
-ifdef CONFIG_GDB_SCRIPTS
-       $(Q)ln -fsn $(abspath $(srctree)/scripts/gdb/vmlinux-gdb.py)
-endif
        +$(call if_changed,link-vmlinux)
 
 targets := vmlinux
@@ -1525,6 +1522,7 @@ $(DOC_TARGETS): scripts_basic FORCE
 PHONY += scripts_gdb
 scripts_gdb: prepare
        $(Q)$(MAKE) $(build)=scripts/gdb
+       $(Q)ln -fsn $(abspath $(srctree)/scripts/gdb/vmlinux-gdb.py)
 
 ifdef CONFIG_GDB_SCRIPTS
 all: scripts_gdb