--- a/drivers/net/wireless/iwlwifi/Makefile
+++ b/drivers/net/wireless/iwlwifi/Makefile
+@@ -1,4 +1,4 @@
+-obj-$(CONFIG_IWLWIFI) += iwlcore.o
++obj-$(CONFIG_COMPAT_IWLWIFI) += iwlcore.o
+ iwlcore-objs := iwl-core.o iwl-eeprom.o iwl-hcmd.o iwl-power.o
+ iwlcore-objs += iwl-rx.o iwl-tx.o iwl-sta.o
+ iwlcore-objs += iwl-scan.o iwl-led.o
@@ -15,7 +15,7 @@ iwlagn-objs += iwl-agn-lib.o iwl-agn-rx
iwlagn-objs += iwl-agn-tt.o
iwlagn-$(CONFIG_IWLWIFI_DEBUGFS) += iwl-agn-debugfs.o
iwlagn-$(CONFIG_IWL5000) += iwl-1000.o
--- a/drivers/net/wireless/iwlwifi/iwl-agn.c
+++ b/drivers/net/wireless/iwlwifi/iwl-agn.c
-@@ -4339,10 +4339,10 @@ static void __devexit iwl_pci_remove(str
+@@ -4450,10 +4450,10 @@ static void __devexit iwl_pci_remove(str
/* Hardware specific file defines the PCI IDs table for that hardware module */
static DEFINE_PCI_DEVICE_TABLE(iwl_hw_card_ids) = {