compat-wireless: rename CONFIG_IWLWIFI config symbol
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 27 Aug 2010 18:40:51 +0000 (11:40 -0700)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Sat, 28 Aug 2010 20:27:59 +0000 (13:27 -0700)
In kernel 2.6.24 CONFIG_IWLWIFI was a bool config symbol and not a
tristate one. In that kernel it was used for showing the menu option for
the Intel driver and not for selection the module it is used for today.
In kernel configurations for version 2.6.24 it is set so y and not to m.
As we do not overwrite some value selected in the kernel config it
will cause problems when we build some parts of the Intel driver in
compat-wireless directly into the kernel.
Now we use an other name for this config symbol to work around the
problem.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
config.mk
patches/08-rename-iwl4965-config.patch

index 4c4a1119db4defffe1849078c54a6da1c3231bb6..110291de7474835ea62848b1b6489a6a8777e473 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -214,7 +214,7 @@ CONFIG_ATH9K_COMMON=m
 # CONFIG_ATH9K_PKTLOG=y
 
 
-CONFIG_IWLWIFI=m
+CONFIG_COMPAT_IWLWIFI=m
 # CONFIG_IWLWIFI_DEBUG=y
 # CONFIG_IWLWIFI_DEBUGFS=y
 # CONFIG_IWLWIFI_DEVICE_TRACING=y
index 568314f63e7a65c06d8dd2be318cf665de7354da..28cd39e547e1bba8aaee1057a1c4852d17bb9c68 100644 (file)
@@ -5,6 +5,12 @@ CONFIG_IWL4965 has to be set to y, to build correctly.
 
 --- a/drivers/net/wireless/iwlwifi/Makefile
 +++ b/drivers/net/wireless/iwlwifi/Makefile
+@@ -1,4 +1,4 @@
+-obj-$(CONFIG_IWLWIFI) += iwlcore.o
++obj-$(CONFIG_COMPAT_IWLWIFI)  += iwlcore.o
+ iwlcore-objs          := iwl-core.o iwl-eeprom.o iwl-hcmd.o iwl-power.o
+ iwlcore-objs          += iwl-rx.o iwl-tx.o iwl-sta.o
+ iwlcore-objs          += iwl-scan.o iwl-led.o
 @@ -15,7 +15,7 @@ iwlagn-objs          += iwl-agn-lib.o iwl-agn-rx
  iwlagn-objs           += iwl-agn-tt.o
  iwlagn-$(CONFIG_IWLWIFI_DEBUGFS) += iwl-agn-debugfs.o
@@ -16,7 +22,7 @@ CONFIG_IWL4965 has to be set to y, to build correctly.
  iwlagn-$(CONFIG_IWL5000) += iwl-1000.o
 --- a/drivers/net/wireless/iwlwifi/iwl-agn.c
 +++ b/drivers/net/wireless/iwlwifi/iwl-agn.c
-@@ -4339,10 +4339,10 @@ static void __devexit iwl_pci_remove(str
+@@ -4450,10 +4450,10 @@ static void __devexit iwl_pci_remove(str
  
  /* Hardware specific file defines the PCI IDs table for that hardware module */
  static DEFINE_PCI_DEVICE_TABLE(iwl_hw_card_ids) = {