config.mk: add support for CONFIG_ATH9K_COMMON
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Fri, 13 Nov 2009 20:04:20 +0000 (12:04 -0800)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Fri, 13 Nov 2009 20:04:35 +0000 (12:04 -0800)
For now this is under PCI but later on once we add ath9k_htc
we'll need to move this under a bus agnostic area.

Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
config.mk

index 8d4916e8660e6901ea99472621b49e861114ceb5..35d607883bca13905d03898e3c9bee6229e5cdca 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -150,6 +150,10 @@ CONFIG_ATH5K=m
 CONFIG_ATH5K_RFKILL=y
 CONFIG_ATH9K_HW=m
 CONFIG_ATH9K=m
+# Note: once ath9k_htc is added we'll have to move
+# CONFIG_ATH9K_COMMON to an area that doesn't depend on PCI
+# as you could then have ath9k disabled but ath9k_htc enabled.
+CONFIG_ATH9K_COMMON=m
 # CONFIG_ATH9K_DEBUG=y