projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
575a35c
)
opkg: use -ffunction-sections, -fdata-sections and --gc-sections
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 2 Mar 2011 12:48:04 +0000
(12:48 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 2 Mar 2011 12:48:04 +0000
(12:48 +0000)
SVN-Revision: 25829
package/opkg/Makefile
patch
|
blob
|
history
diff --git
a/package/opkg/Makefile
b/package/opkg/Makefile
index 25cdc524c6d999527b7043bfc51b8d8b9f45a959..0b07d5b49965d2957be55ba045f57704b465e8c7 100644
(file)
--- a/
package/opkg/Makefile
+++ b/
package/opkg/Makefile
@@
-46,6
+46,7
@@
define Package/opkg/conffiles
endef
TARGET_CFLAGS += $(if $(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4),-Wno-array-bounds)
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
CONFIGURE_ARGS += \
@@
-59,6
+60,7
@@
define Build/Compile
CC="$(TARGET_CC)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
HOST_CPU="$(PKGARCH)" \
+ LDFLAGS="-Wl,--gc-sections" \
all install
endef