hostapd: split long lines
authorLeon M. Busch-George <leon@georgemail.eu>
Mon, 19 Feb 2024 11:49:28 +0000 (12:49 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Sun, 10 Nov 2024 01:15:56 +0000 (02:15 +0100)
These two were getting rather long.

Signed-off-by: Leon M. Busch-George <leon@georgemail.eu>
Link: https://github.com/openwrt/openwrt/pull/16849
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
package/network/services/hostapd/Makefile

index 0e3396262d0c13600534ef443d8abba8a348a959..16dfbff2b06d5cc4686415d4a614f17f12e4b446 100644 (file)
@@ -84,7 +84,11 @@ ifneq ($(CONFIG_DRIVER_11BE_SUPPORT),)
   HOSTAPD_IEEE80211BE:=y
 endif
 
-CORE_DEPENDS = +ucode +libubus +libucode +ucode-mod-fs +ucode-mod-nl80211 +ucode-mod-rtnl +ucode-mod-ubus +ucode-mod-uloop +libblobmsg-json +libudebug
+
+CORE_DEPENDS = +ucode +libucode \
+       +ucode-mod-fs +ucode-mod-nl80211 +ucode-mod-rtnl +ucode-mod-ubus +ucode-mod-uloop \
+       +libubus +libblobmsg-json \
+       +libudebug
 OPENSSL_DEPENDS = +PACKAGE_$(1):libopenssl +PACKAGE_$(1):libopenssl-legacy
 
 DRIVER_MAKEOPTS= \
@@ -716,7 +720,13 @@ define Install/supplicant
 endef
 
 define Package/hostapd-common/install
-       $(INSTALL_DIR) $(1)/etc/capabilities $(1)/etc/rc.button $(1)/etc/hotplug.d/ieee80211 $(1)/etc/init.d $(1)/lib/netifd  $(1)/usr/share/acl.d $(1)/usr/share/hostap
+       $(INSTALL_DIR) \
+         $(1)/etc/capabilities \
+         $(1)/etc/rc.button \
+         $(1)/etc/hotplug.d/ieee80211 \
+         $(1)/etc/init.d $(1)/lib/netifd \
+         $(1)/usr/share/acl.d \
+         $(1)/usr/share/hostap
        $(INSTALL_BIN) ./files/dhcp-get-server.sh $(1)/lib/netifd/dhcp-get-server.sh
        $(INSTALL_BIN) ./files/wpad.init $(1)/etc/init.d/wpad
        $(INSTALL_BIN) ./files/wps-hotplug.sh $(1)/etc/rc.button/wps