sunxi: respect CONFIG_TARGET_IMAGES_GZIP
authorJohn Crispin <john@openwrt.org>
Tue, 1 Mar 2016 08:14:38 +0000 (08:14 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 1 Mar 2016 08:14:38 +0000 (08:14 +0000)
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Backport of r46608

SVN-Revision: 48836

target/linux/sunxi/image/Makefile

index 19ab935f3b80f942b5b2f9a69f66d85cc8c67497..d3f440941d4a5a6f0f5b596398743b3bdc353910 100644 (file)
@@ -43,6 +43,10 @@ define Image/Build/SDCard
                $(CONFIG_SUNXI_SD_BOOT_PARTSIZE) \
                $(CONFIG_TARGET_ROOTFS_PARTSIZE) \
                $(KDIR)/uboot-sunxi-$(PROFILE)-u-boot-with-spl.bin
+
+  ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
+       gzip -f9n $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-sdcard-vfat-$(1).img
+  endif
 endef
 
 define Image/Build/Profile/A10-OLinuXino-Lime