projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9f816bf
)
add prereq check to prevent people from building openwrt as root
author
Felix Fietkau
<nbd@openwrt.org>
Thu, 24 Aug 2006 18:49:51 +0000
(18:49 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Thu, 24 Aug 2006 18:49:51 +0000
(18:49 +0000)
SVN-Revision: 4655
openwrt/include/prereq-build.mk
patch
|
blob
|
history
diff --git
a/openwrt/include/prereq-build.mk
b/openwrt/include/prereq-build.mk
index a6de9b270aa74d784e70071055cdd1ae10c0d517..e90c3157b050a5e1ebc9097ac6855f5dcf799480 100644
(file)
--- a/
openwrt/include/prereq-build.mk
+++ b/
openwrt/include/prereq-build.mk
@@
-8,6
+8,13
@@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/prereq.mk
+define Require/non-root
+ [ "$$(shell whoami)" != "root" ]
+endef
+$(eval $(call Require,non-root, \
+ Building OpenWrt as root is not supported! \
+))
+
# Required for the toolchain
define Require/working-make
echo 'all: test' > $(TMP_DIR)/check.mk