projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
13fef7f
)
powerpc/44x: Simplify CONFIG_44x checks in Makefile
author
Michael Ellerman
<mpe@ellerman.id.au>
Tue, 8 Aug 2017 06:39:18 +0000
(16:39 +1000)
committer
Michael Ellerman
<mpe@ellerman.id.au>
Thu, 10 Aug 2017 13:29:03 +0000
(23:29 +1000)
The entire 44x directory is omitted if CONFIG_44x is not enabled, so
within the 44x/Makefile CONFIG_44x is always y. So convert
obj-$(CONFIG_44x) to the more obvious obj-y.
Signed-off-by: Michael Ellerman <mpe@ellerman.id.au>
arch/powerpc/platforms/44x/Makefile
patch
|
blob
|
history
diff --git
a/arch/powerpc/platforms/44x/Makefile
b/arch/powerpc/platforms/44x/Makefile
index 72b824160660e0b9302216318ea6d16598f3f5bc..71a7fccef675f044736757ee135ddbedd0def167 100644
(file)
--- a/
arch/powerpc/platforms/44x/Makefile
+++ b/
arch/powerpc/platforms/44x/Makefile
@@
-1,6
+1,6
@@
-obj-
$(CONFIG_44x)
+= misc_44x.o
+obj-
y
+= misc_44x.o
ifneq ($(CONFIG_PPC4xx_CPM),y)
-obj-
$(CONFIG_44x)
+= idle.o
+obj-
y
+= idle.o
endif
obj-$(CONFIG_PPC44x_SIMPLE) += ppc44x_simple.o
obj-$(CONFIG_EBONY) += ebony.o