Apply ptunnel patches from #2884
authorFlorian Fainelli <florian@openwrt.org>
Thu, 10 Jan 2008 18:25:04 +0000 (18:25 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 10 Jan 2008 18:25:04 +0000 (18:25 +0000)
SVN-Revision: 10160

net/ptunnel/Makefile
net/ptunnel/files/ptunnel.conf [new file with mode: 0644]
net/ptunnel/files/ptunnel.init

index d4aada558c58ba412544c772374e8c91aa73973f..91764bb3e50dd0be75a397ea4633a81346b62a20 100644 (file)
@@ -49,6 +49,8 @@ define Package/ptunnel/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ptunnel $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/ptunnel.init $(1)/etc/init.d/ptunnel
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/ptunnel.conf $(1)/etc/config/ptunnel
 endef
 
 $(eval $(call BuildPackage,ptunnel))
diff --git a/net/ptunnel/files/ptunnel.conf b/net/ptunnel/files/ptunnel.conf
new file mode 100644 (file)
index 0000000..35781f9
--- /dev/null
@@ -0,0 +1,3 @@
+config ptunnel
+        option interface 'br-lan'
+       
\ No newline at end of file
index da3b1433720a3ea72904d6802a92946e3965ad29..f834bd49bb850cc01693f0993de30843e7c11eb2 100644 (file)
@@ -1,14 +1,27 @@
 #!/bin/sh /etc/rc.common
 # Copyright (C) 2007 OpenWrt.org
 START=70
-STOP=70
+BIN=ptunnel
 
 start() {
-        iptables -I OUTPUT 1 -p icmp -j ACCEPT
-       ptunnel -v 1 -c br-lan
+    config_load ptunnel
+    config_foreach start_ptunnel ptunnel
 }
-               
+
+start_ptunnel() {
+    local section="$1"
+    
+    include /lib/network
+    scan_interfaces
+    
+    iptables -I OUTPUT 1 -p icmp -j ACCEPT
+    config_get interface "$section" interface
+
+    $BIN -c "$interface" > /dev/null&
+}
+
 stop() {
-        killall ptunnel
+        ps aux | grep ptunnel |  awk '{print }' | \
+            xargs kill 2> /dev/null
 }
-                       
\ No newline at end of file
+                                                                       
\ No newline at end of file