projects
/
openwrt
/
staging
/
ynezz.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
dbeb0fa
)
use $(TAR) instead of tar
author
Felix Fietkau
<nbd@openwrt.org>
Sat, 29 Sep 2007 00:16:33 +0000
(
00:16
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sat, 29 Sep 2007 00:16:33 +0000
(
00:16
+0000)
SVN-Revision: 9058
include/download.mk
patch
|
blob
|
history
diff --git
a/include/download.mk
b/include/download.mk
index 1f227e221c8dafc624d0b69e56e628f1a0371637..3866242805c212cd9ba9e346fdc57e149e2f2f68 100644
(file)
--- a/
include/download.mk
+++ b/
include/download.mk
@@
-23,8
+23,8
@@
$(strip \
endef
# code for creating tarballs from svn/git checkouts - useful for mirror support
-dl_pack/bz2=
tar
cfj $(1) $(2)
-dl_pack/gz=
tar
cfz $(1) $(2)
+dl_pack/bz2=
$(TAR)
cfj $(1) $(2)
+dl_pack/gz=
$(TAR)
cfz $(1) $(2)
dl_pack/unknown=echo "ERROR: Unknown pack format for file $(1)"; false
define dl_pack
$(if $(dl_pack/$(call ext,$(1))),$(dl_pack/$(call ext,$(1))),$(dl_pack/unknown))