ipq-wifi: fix upstream board-2.bin ZTE M289F snafu
authorChristian Lamparter <chunkeey@gmail.com>
Tue, 4 Jul 2023 18:42:22 +0000 (20:42 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Tue, 4 Jul 2023 20:11:08 +0000 (22:11 +0200)
The upstream board-2.bin file in the linux-firmware.git
repository for the QCA4019 contains a packed board-2.bin
for this device for both 2.4G and 5G wifis. This isn't
something that the ath10k driver supports.

Until this feature either gets implemented - which is
very unlikely -, or the upstream boardfile is mended
(both, the original submitter and ath10k-firmware
custodian have been notified). OpenWrt will go back
and use its own bespoke boardfile. This unfortunately
means that 2.4G and on some revisions the 5G WiFi is
not available in the initramfs image for this device.

Fixes: #12886
Reported-by: Christian Heuff <christian@heuff.at>
Debugged-by: Georgios Kourachanis <geo.kourachanis@gmail.com>
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
(cherry picked from commit 75505c5ec724b9b961dcb411bac1d4b9aede3e1d)

package/firmware/ipq-wifi/Makefile
target/linux/ipq40xx/image/generic.mk

index faee191c349e1f71cc93c4be9d768a046feb407f..8936a1dd60a55fd12024b593898d980e38b4753f 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=ipq-wifi
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/firmware/qca-wireless.git
@@ -40,6 +40,7 @@ ALLWIFIBOARDS:= \
        wallys_dr40x9 \
        xiaomi_ax3600 \
        xiaomi_ax9000 \
+       zte_mf289f \
        zte_mf287plus \
        zyxel_nbg7815
 
@@ -127,6 +128,7 @@ $(eval $(call generate-ipq-wifi-package,redmi_ax6,Redmi AX6))
 $(eval $(call generate-ipq-wifi-package,wallys_dr40x9,Wallys DR40X9))
 $(eval $(call generate-ipq-wifi-package,xiaomi_ax3600,Xiaomi AX3600))
 $(eval $(call generate-ipq-wifi-package,xiaomi_ax9000,Xiaomi AX9000))
+$(eval $(call generate-ipq-wifi-package,zte_mf289f,ZTE MF289F))
 $(eval $(call generate-ipq-wifi-package,zte_mf287plus,ZTE MF287Plus))
 $(eval $(call generate-ipq-wifi-package,zyxel_nbg7815,Zyxel NBG7815))
 
index b9e9e478d9f4708327b4aae4d05769c2eb4b9a07..f15463ae8ca5e6be03e62645a5dec0848c40ac5d 100644 (file)
@@ -1169,7 +1169,7 @@ TARGET_DEVICES += zte_mf287plus
 define Device/zte_mf289f
        $(call Device/zte_mf28x_common)
        DEVICE_MODEL := MF289F
-       DEVICE_PACKAGES += ath10k-firmware-qca9984-ct
+       DEVICE_PACKAGES += ipq-wifi-zte_mf289f ath10k-firmware-qca9984-ct
 endef
 TARGET_DEVICES += zte_mf289f