added a make package
authorJohn Crispin <john@openwrt.org>
Sun, 7 Oct 2007 00:48:52 +0000 (00:48 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 7 Oct 2007 00:48:52 +0000 (00:48 +0000)
SVN-Revision: 9168

utils/make/Makefile [new file with mode: 0644]

diff --git a/utils/make/Makefile b/utils/make/Makefile
new file mode 100644 (file)
index 0000000..06153f1
--- /dev/null
@@ -0,0 +1,48 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=make
+PKG_VERSION:=3.81
+PKG_RELEASE:=1
+PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/make/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=354853e0b2da90c527e35aabb8d6f1e6
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/make
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=make
+endef
+
+define Package/make/description
+       The Make package contains a program for compiling packages
+endef
+
+define Build/Configure
+       (cd  $(PKG_BUILD_DIR)/; \
+               $(TARGET_CONFIGURE_OPTS) \
+               $(CONFIGURE_VARS) \
+               $(CONFIGURE_CMD) \
+               $(CONFIGURE_ARGS_XTRA) \
+               $(CONFIGURE_ARGS) \
+       );
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) all
+       $(MAKE) -C $(PKG_BUILD_DIR) install DESTDIR=$(PKG_INSTALL_DIR)
+endef
+
+define Package/make/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/make $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,make))