projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1d234cf
)
uboot-mvebu: don't install 64bit binaries
author
Andre Heider
<a.heider@gmail.com>
Wed, 23 Sep 2020 00:59:47 +0000
(
02:59
+0200)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sun, 11 Oct 2020 14:38:16 +0000
(16:38 +0200)
u-boot binaries are not useful for these boards, they need to be combined
with atf for a proper firmware.
Signed-off-by: Andre Heider <a.heider@gmail.com>
package/boot/uboot-mvebu/Makefile
patch
|
blob
|
history
diff --git
a/package/boot/uboot-mvebu/Makefile
b/package/boot/uboot-mvebu/Makefile
index 903b9da5fff149ae99370f7def394adeca6103c1..25dd2526e54052329b20920aee16a530913c414d 100644
(file)
--- a/
package/boot/uboot-mvebu/Makefile
+++ b/
package/boot/uboot-mvebu/Makefile
@@
-70,6
+70,10
@@
define Build/Configure
$(call Build/Configure/U-Boot)
endef
+define Package/u-boot/install
+ $(if $(findstring cortexa53,$(BUILD_SUBTARGET)),,$(Package/u-boot/install/default))
+endef
+
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
$(CP) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-$(UBOOT_IMAGE)