projects
/
openwrt
/
staging
/
ansuel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
c38691f
)
prereq check for find -exec +
author
Mike Baker
<mbm@openwrt.org>
Thu, 12 Apr 2007 18:17:38 +0000
(18:17 +0000)
committer
Mike Baker
<mbm@openwrt.org>
Thu, 12 Apr 2007 18:17:38 +0000
(18:17 +0000)
SVN-Revision: 6940
include/prereq-build.mk
patch
|
blob
|
history
diff --git
a/include/prereq-build.mk
b/include/prereq-build.mk
index d3aec643999c81501b5adc8f73d7189097dfc6ac..7355b9e31c1e3c8cad24fd54897159717c3d8555 100644
(file)
--- a/
include/prereq-build.mk
+++ b/
include/prereq-build.mk
@@
-121,3
+121,11
@@
$(eval $(call Require,gnutar, \
$(eval $(call RequireCommand,autoconf, \
Please install GNU autoconf. \
))
+
+define Require/find
+ find . -maxdepth 1 -exec ls {} + > /dev/null 2>&1
+endef
+
+$(eval $(call Require,find, \
+ Please install GNU find 4.2.12 or better. \
+))