kirkwood: Add Marvell RTC to two devices
authorLinus Walleij <linus.walleij@linaro.org>
Sat, 1 Jun 2024 20:29:59 +0000 (22:29 +0200)
committerLinus Walleij <linus.walleij@linaro.org>
Fri, 7 Jun 2024 19:48:42 +0000 (21:48 +0200)
The recently added D-Link DNS-320L and the Zyxel NSA310S
is missing an RTC module so let's give them the default
Marvell RTC at least.

Reviewed-by: Robert Marko <robimarko@gmail.com>
Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
target/linux/kirkwood/image/Makefile

index 48de5bee2b846611ca185ff4f4daf057ae10d832..2bd2f6415987ea3c109507b949961bc1d99ddfd7 100644 (file)
@@ -186,7 +186,7 @@ define Device/dlink_dns320l
   DEVICE_VENDOR := D-Link
   DEVICE_MODEL := DNS-320L
   DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-fs-ext4 kmod-gpio-button-hotplug \
-       kmod-usb-storage kmod-usb-ledtrig-usbport dns320l-mcu
+       kmod-usb-storage kmod-usb-ledtrig-usbport dns320l-mcu kmod-rtc-mv
 endef
 TARGET_DEVICES += dlink_dns320l
 
@@ -386,7 +386,8 @@ TARGET_DEVICES += zyxel_nsa310b
 define Device/zyxel_nsa310s
   DEVICE_VENDOR := ZyXEL
   DEVICE_MODEL := NSA310S
-  DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-fs-ext4 kmod-gpio-button-hotplug
+  DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-fs-ext4 \
+       kmod-gpio-button-hotplug kmod-rtc-mv
 endef
 TARGET_DEVICES += zyxel_nsa310s