projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
0f4a0fa
)
speed up the build system a little bit
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 12 Nov 2006 01:49:35 +0000
(
01:49
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 12 Nov 2006 01:49:35 +0000
(
01:49
+0000)
SVN-Revision: 5506
include/host.mk
patch
|
blob
|
history
rules.mk
patch
|
blob
|
history
diff --git
a/include/host.mk
b/include/host.mk
index ed961e35d91a662d4427166d4adcdc9731ea3ebd..1130d5b9a623a52682811c3d116b6593793821fd 100644
(file)
--- a/
include/host.mk
+++ b/
include/host.mk
@@
-11,6
+11,7
@@
export TAR
$(TMP_DIR)/.host.mk: $(INCLUDE_DIR)/host.mk
@( \
+ echo -n "BASH:=$(shell which bash)"; \
HOST_OS=`uname`; \
case "$$HOST_OS" in \
Linux) HOST_ARCH=`uname -m`;; \
diff --git
a/rules.mk
b/rules.mk
index da0e04c1c4139b5013707276dd08bfdbc43474f3..d52539f3f2b80b0d6a5fd1521a31685720570104 100644
(file)
--- a/
rules.mk
+++ b/
rules.mk
@@
-9,7
+9,6
@@
include $(TOPDIR)/include/verbose.mk
export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' --
-export BASH=$(shell which bash)
ARCH:=$(strip $(subst ",, $(CONFIG_ARCH)))
TARGET_OPTIMIZATION:=$(strip $(subst ",, $(CONFIG_TARGET_OPTIMIZATION)))