Revert "tools/automake: bump to 1.17"
authorRobert Marko <robimarko@gmail.com>
Mon, 24 Feb 2025 11:27:47 +0000 (12:27 +0100)
committerRobert Marko <robimarko@gmail.com>
Mon, 24 Feb 2025 11:27:47 +0000 (12:27 +0100)
This reverts commit b930ce3bf7aa350cf0252dbf95c9447e51be4de9.

Bump to 1.17 broke SDK portability as it partially reverted commit
("automake: portability fixes") which made Perl PATH "/usr/bin/env perl"
as that is portable, as otherwise automake will set the absolute path to
the Perl binary and this will then fail when using SDK on a different
system as that PATH is not present.

So, since fixing this would require backport of upstream commit
("configure: make perl path with whitespace a warning, not error.") which
requires autoreconf to be done in order for configure to get regenerated
we cannot do it because at that time we do not have automake built.

So, for now revert the bump until upstream makes a new release.

Signed-off-by: Robert Marko <robimarko@gmail.com>
tools/automake/Makefile
tools/automake/patches/000-relocatable.patch
tools/automake/patches/100-aclocal-skip-not-existing-directories.patch
tools/automake/patches/101-do-not-require-files.patch
tools/automake/patches/200-other-V-values-for-verbosity.patch

index dddc0a148fc842f716a4fc64c99adb20c0130aa2..7f129c1d838708ad8303e337bac5571589499e80 100644 (file)
@@ -8,12 +8,12 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=automake
 PKG_CPE_ID:=cpe:/a:gnu:automake
-PKG_VERSION:=1.17
+PKG_VERSION:=1.16.5
 PKG_API_VERSION:=$(word 2,$(subst ., ,$(PKG_VERSION)))
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/automake
-PKG_HASH:=8920c1fc411e13b90bf704ef9db6f29d540e76d232cb3b2c9f4dc4cc599bd990
+PKG_HASH:=07bd24ad08a64bc17250ce09ec56e921d6343903943e99ccf63bbf0705e34605
 
 include $(INCLUDE_DIR)/host-build.mk
 
@@ -21,7 +21,7 @@ HOST_CONFIGURE_ARGS += \
        --disable-silent-rules
 
 HOST_CONFIGURE_VARS += \
-       PERL="$(shell command -v perl)" \
+       PERL="/usr/bin/env perl" \
        am_cv_prog_PERL_ithreads=no
 
 define Host/Configure
index 5dcda2829e70e70486e37e951fa200df23f304d6..0b61eaeb45a85101d76d68b58797e939648516ff 100644 (file)
@@ -11,7 +11,7 @@
  # We need at least this version for CLONE support.
 --- a/bin/aclocal.in
 +++ b/bin/aclocal.in
-@@ -23,10 +23,12 @@ use 5.006;
+@@ -23,9 +23,11 @@ use 5.006;
  use strict;
  use warnings FATAL => 'all';
  
  BEGIN
  {
 -  unshift (@INC, '@datadir@/@PACKAGE@-@APIVERSION@')
--    unless $ENV{AUTOMAKE_UNINSTALLED};
 +  unshift (@INC, ($ENV{'STAGING_DIR_HOST'} ? $ENV{'STAGING_DIR_HOST'} . '/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@'))
-+     unless $ENV{AUTOMAKE_UNINSTALLED};
+     unless $ENV{AUTOMAKE_UNINSTALLED};
  }
  
- use File::Basename;
 @@ -65,8 +67,8 @@ $perl_threads = 0;
- # --aclocal-path option/ACLOCAL_PATH environment variable, and reset
- # with the '--system-acdir' option.
+ # ACLOCAL_PATH environment variable, and reset with the '--system-acdir'
+ # option.
  my @user_includes = ();
 -my @automake_includes = ('@datadir@/aclocal-' . $APIVERSION);
 -my @system_includes = ('@datadir@/aclocal');
 +my @automake_includes = ($ENV{'STAGING_DIR_HOST'} ? $ENV{'STAGING_DIR_HOST'} . "/share/aclocal-$APIVERSION" : "@datadir@/aclocal-$APIVERSION");
 +my @system_includes = ($ENV{'STAGING_DIR_HOST'} ? $ENV{'STAGING_DIR_HOST'} . '/share/aclocal' : '@datadir@/aclocal');
- my $aclocal_path = '';
  
  # Whether we should copy M4 file in $user_includes[0].
+ my $install = 0;
 --- a/bin/automake.in
 +++ b/bin/automake.in
 @@ -26,9 +26,11 @@ use 5.006;
index 6fa23c49e813c01c9f38941699a028c2be6de492..a0d04e21e5fdc437927bc76e8ab5b78997f855d3 100644 (file)
@@ -1,6 +1,6 @@
 --- a/bin/aclocal.in
 +++ b/bin/aclocal.in
-@@ -372,6 +372,12 @@ sub scan_m4_dirs ($$@)
+@@ -371,6 +371,12 @@ sub scan_m4_dirs ($$@)
  
    foreach my $m4dir (@dirlist)
      {
index 26847bc6808284539af7b8886277748131dc7352..3a8c9fcb47b1ae2ff31eee0f59bb232c828d5aca 100644 (file)
@@ -1,6 +1,6 @@
 --- a/bin/automake.in
 +++ b/bin/automake.in
-@@ -4552,7 +4552,7 @@ sub handle_gettext ()
+@@ -4513,7 +4513,7 @@ sub handle_gettext ()
            && grep ($_ eq 'intl', @subdirs));
      }
  
@@ -9,7 +9,7 @@
  }
  
  # Emit makefile footer.
-@@ -5677,7 +5677,7 @@ sub check_gnu_standards ()
+@@ -5641,7 +5641,7 @@ sub check_gnu_standards ()
            # otherwise require non-.md.
            my $required
             = (! -f $file && -f "$file.md") ? "$file.md" : $file;
@@ -18,7 +18,7 @@
          }
  
        # Accept one of these three licenses; default to COPYING.
-@@ -5691,7 +5691,7 @@ sub check_gnu_standards ()
+@@ -5655,7 +5655,7 @@ sub check_gnu_standards ()
              last;
            }
        }
index 8a5a2d31bdb8587278b10ccc2ee964788df0588a..1ea9d38b0ed1013a9ecaa4559d97132b30b29404 100644 (file)
@@ -9,8 +9,8 @@ Subject: [PATCH] Allow other V values for verbosity
 
 --- a/m4/silent.m4
 +++ b/m4/silent.m4
-@@ -53,7 +53,7 @@ case $enable_silent_rules in @%:@ (((
- esac
+@@ -43,7 +43,7 @@ else
+ fi])
  if test $am_cv_make_support_nested_variables = yes; then
    dnl Using '$V' instead of '$(V)' breaks IRIX make.
 -  AM_V='$(V)'