uboot-sunxi: Check for swig
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 13 Feb 2022 17:23:07 +0000 (18:23 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 13 Feb 2022 17:23:07 +0000 (18:23 +0100)
package/boot/uboot-sunxi/Makefile
package/boot/uboot-sunxi/patches/210-sunxi-deactivate-binman.patch [deleted file]

index 5c27407d155116a9940560ddf30a81812de3cc10..16ea9c13dcccbcc19e8788aba38f16b986cac32c 100644 (file)
@@ -15,6 +15,8 @@ PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
 
 PKG_MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
 
+NEEDS_SWIG:=1
+
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
 
diff --git a/package/boot/uboot-sunxi/patches/210-sunxi-deactivate-binman.patch b/package/boot/uboot-sunxi/patches/210-sunxi-deactivate-binman.patch
deleted file mode 100644 (file)
index 5efebbd..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-From def280c4792262a368c8861312dc6b376181021f Mon Sep 17 00:00:00 2001
-From: Hauke Mehrtens <hauke@hauke-m.de>
-Date: Mon, 1 Jan 2018 23:10:56 +0100
-Subject: sunxi: deactivate binman
-
-Use the old way to generate the images instead of binman.
-binman needs python with swig to avoid this host tool dependency use the
-old way of generating images.
----
- Makefile | 7 ++++---
- 1 file changed, 4 insertions(+), 3 deletions(-)
-
---- a/Makefile
-+++ b/Makefile
-@@ -1555,8 +1555,10 @@ endif
- ifneq ($(CONFIG_ARCH_SUNXI),)
- ifeq ($(CONFIG_ARM64),)
--u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.img u-boot.dtb FORCE
--      $(call if_changed,binman)
-+OBJCOPYFLAGS_u-boot-sunxi-with-spl.bin = -I binary -O binary \
-+                              --pad-to=$(CONFIG_SPL_PAD_TO) --gap-fill=0xff
-+u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.img FORCE
-+      $(call if_changed,pad_cat)
- else
- u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.itb FORCE
-       $(call if_changed,cat)
---- a/arch/arm/Kconfig
-+++ b/arch/arm/Kconfig
-@@ -962,7 +962,6 @@ config ARCH_SOCFPGA
- config ARCH_SUNXI
-       bool "Support sunxi (Allwinner) SoCs"
--      select BINMAN
-       select CMD_GPIO
-       select CMD_MMC if MMC
-       select CMD_USB if DISTRO_DEFAULTS