ath10k-ct: bump to version 6.9
authorHannu Nyman <hannu.nyman@iki.fi>
Tue, 30 Jul 2024 16:17:31 +0000 (19:17 +0300)
committerRobert Marko <robimarko@gmail.com>
Mon, 12 Aug 2024 18:56:59 +0000 (20:56 +0200)
Use ath10k-ct 6.9 to better match mac80211 backports 6.9.x

Drop patch 010 that is merged upstream.
Add patch 001 to fix version to 6.9 (overlooked by upstream).
Refresh patches.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Link: https://github.com/openwrt/openwrt/pull/16036
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/kernel/ath10k-ct/Makefile
package/kernel/ath10k-ct/patches/001-patch-version.patch [new file with mode: 0644]
package/kernel/ath10k-ct/patches/010-mac80211_backport.patch [deleted file]
package/kernel/ath10k-ct/patches/130-ath10k-read-qcom-coexist-support-as-a-u32.patch
package/kernel/ath10k-ct/patches/201-wifi-ath10k-add-LED-and-GPIO-controlling-support-for.patch
package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch
package/kernel/ath10k-ct/patches/300-fix-fortify-checking-error.patch
package/kernel/ath10k-ct/patches/960-0010-ath10k-limit-htt-rx-ring-size.patch
package/kernel/ath10k-ct/patches/960-0011-ath10k-limit-pci-buffer-size.patch
package/kernel/ath10k-ct/patches/988-ath10k-always-use-mac80211-loss-detection.patch

index 53d9eec1eac23cb585febde72ce6ce09b67c5757..bd18930801d979455f9a6a3f7867e97aa74d8769 100644 (file)
@@ -8,14 +8,14 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/greearb/ath10k-ct.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2024-03-03
-PKG_SOURCE_VERSION:=eb3f488a200fafc46140fd51b5e21f737ee50f24
-PKG_MIRROR_HASH:=368ed648dc7239dbcac3c6ba09be92c4b706118052d35e058cf5d1dae2917039
+PKG_SOURCE_DATE:=2024-07-30
+PKG_SOURCE_VERSION:=ac71b14dc93aef0af6f0f24808b0afb673eaa5f5
+PKG_MIRROR_HASH:=f7774fc7002bbea450f543927acd528fb1bb6742f0e9ef28a402df3796893d93
 
-# Build the 6.7 ath10k-ct driver version.
+# Build the 6.9 ath10k-ct driver version.
 # Probably this should match as closely as
 # possible to whatever mac80211 backports version is being used.
-CT_KVER="-6.7"
+CT_KVER="-6.9"
 
 PKG_MAINTAINER:=Ben Greear <greearb@candelatech.com>
 PKG_BUILD_PARALLEL:=1
diff --git a/package/kernel/ath10k-ct/patches/001-patch-version.patch b/package/kernel/ath10k-ct/patches/001-patch-version.patch
new file mode 100644 (file)
index 0000000..e5ae723
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/ath10k-6.9/pci.c
++++ b/ath10k-6.9/pci.c
+@@ -3871,7 +3871,7 @@ static int __ath10k_pci_probe(struct pci
+       int (*pci_hard_reset)(struct ath10k *ar);
+       u32 (*targ_cpu_to_ce_addr)(struct ath10k *ar, u32 addr);
+-      printk(KERN_INFO "ath10k 6.7 driver, optimized for CT firmware, probing pci device: 0x%x.\n",
++      printk(KERN_INFO "ath10k 6.9 driver, optimized for CT firmware, probing pci device: 0x%x.\n",
+              pci_dev->device);
+       switch (pci_dev->device) {
diff --git a/package/kernel/ath10k-ct/patches/010-mac80211_backport.patch b/package/kernel/ath10k-ct/patches/010-mac80211_backport.patch
deleted file mode 100644 (file)
index 6c9cfdf..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
---- a/ath10k-6.7/mac.c
-+++ b/ath10k-6.7/mac.c
-@@ -2304,8 +2304,8 @@ static void ath10k_mac_vif_ap_csa_count_
-       if (!arvif->is_up)
-               return;
--      if (!ieee80211_beacon_cntdwn_is_complete(vif)) {
--              ieee80211_beacon_update_cntdwn(vif);
-+      if (!ieee80211_beacon_cntdwn_is_complete(vif, 0)) {
-+              ieee80211_beacon_update_cntdwn(vif, 0);
-               ret = ath10k_mac_setup_bcn_tmpl(arvif);
-               if (ret)
-@@ -2317,7 +2317,7 @@ static void ath10k_mac_vif_ap_csa_count_
-                       ath10k_warn(ar, "failed to update prb tmpl during csa: %d\n",
-                                   ret);
-       } else {
--              ieee80211_csa_finish(vif);
-+              ieee80211_csa_finish(vif, 0);
-       }
- }
---- a/ath10k-6.7/wmi.c
-+++ b/ath10k-6.7/wmi.c
-@@ -4292,8 +4292,8 @@ void ath10k_wmi_event_host_swba(struct a
-                * actual channel switch is done
-                */
-               if (arvif->vif->bss_conf.csa_active &&
--                  ieee80211_beacon_cntdwn_is_complete(arvif->vif)) {
--                      ieee80211_csa_finish(arvif->vif);
-+                  ieee80211_beacon_cntdwn_is_complete(arvif->vif, 0)) {
-+                      ieee80211_csa_finish(arvif->vif, 0);
-                       continue;
-               }
index f5fc3b2ec8030d3d0ba1c0986fddce8df77e92a2..b15bfdde6a584d858450ceb5e1b4bee5f89f89d1 100644 (file)
@@ -39,9 +39,9 @@ that the feature is properly initialized:
 
 Signed-off-by: Vincent Tremblay <vincent@vtremblay.dev>
 
---- a/ath10k-6.7/core.c
-+++ b/ath10k-6.7/core.c
-@@ -2869,14 +2869,14 @@ done:
+--- a/ath10k-6.9/core.c
++++ b/ath10k-6.9/core.c
+@@ -2889,14 +2889,14 @@ done:
  static void ath10k_core_fetch_btcoex_dt(struct ath10k *ar)
  {
        struct device_node *node;
index 701fbb9e6f52ea8185700815ee1b3bcce9271f8f..ba9372f9f05cc2040c4c3c8a5d765171c208793a 100644 (file)
@@ -20,25 +20,25 @@ Tested-by: Stefan Lippers-Hollmann <s.l-h@gmx.de>
 Signed-off-by: Kalle Valo <quic_kvalo@quicinc.com>
 Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
 ---
- ath10k-6.7/Kconfig   |  6 ++
- ath10k-6.7/Makefile  |  1 +
- ath10k-6.7/core.c    | 32 ++++++++
- ath10k-6.7/core.h    |  8 ++
- ath10k-6.7/hw.h      |  1 +
- ath10k-6.7/leds.c    | 90 +++++++++++++++++++++++
- ath10k-6.7/leds.h    | 34 +++++++++
- ath10k-6.7/mac.c     |  1 +
- ath10k-6.7/wmi-ops.h | 32 ++++++++
- ath10k-6.7/wmi-tlv.c |  2 +
- ath10k-6.7/wmi.c     | 54 ++++++++++++++
- ath10k-6.7/wmi.h     | 35 +++++++++
+ ath10k-6.9/Kconfig   |  6 ++
+ ath10k-6.9/Makefile  |  1 +
+ ath10k-6.9/core.c    | 32 ++++++++
+ ath10k-6.9/core.h    |  8 ++
+ ath10k-6.9/hw.h      |  1 +
+ ath10k-6.9/leds.c    | 90 +++++++++++++++++++++++
+ ath10k-6.9/leds.h    | 34 +++++++++
+ ath10k-6.9/mac.c     |  1 +
+ ath10k-6.9/wmi-ops.h | 32 ++++++++
+ ath10k-6.9/wmi-tlv.c |  2 +
+ ath10k-6.9/wmi.c     | 54 ++++++++++++++
+ ath10k-6.9/wmi.h     | 35 +++++++++
  12 files changed, 296 insertions(+)
- create mode 100644 ath10k-6.7/leds.c
- create mode 100644 ath10k-6.7/leds.h
+ create mode 100644 ath10k-6.9/leds.c
+ create mode 100644 ath10k-6.9/leds.h
 
---- a/ath10k-6.7/Kconfig
-+++ b/ath10k-6.7/Kconfig
-@@ -67,6 +67,12 @@ config ATH10K_DEBUGFS
+--- a/ath10k-6.9/Kconfig
++++ b/ath10k-6.9/Kconfig
+@@ -68,6 +68,12 @@ config ATH10K_DEBUGFS
  
          If unsure, say Y to make it easier to debug problems.
  
@@ -51,8 +51,8 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  config ATH10K_SPECTRAL
        bool "Atheros ath10k spectral scan support"
        depends on ATH10K_DEBUGFS
---- a/ath10k-6.7/Makefile
-+++ b/ath10k-6.7/Makefile
+--- a/ath10k-6.9/Makefile
++++ b/ath10k-6.9/Makefile
 @@ -20,6 +20,7 @@ ath10k_core-$(CONFIG_ATH10K_SPECTRAL) +=
  ath10k_core-$(CONFIG_NL80211_TESTMODE) += testmode.o
  ath10k_core-$(CONFIG_ATH10K_TRACING) += trace.o
@@ -61,9 +61,9 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  ath10k_core-$(CONFIG_MAC80211_DEBUGFS) += debugfs_sta.o
  ath10k_core-$(CONFIG_PM) += wow.o
  ath10k_core-$(CONFIG_ATH10K_CE) += ce.o
---- a/ath10k-6.7/core.c
-+++ b/ath10k-6.7/core.c
-@@ -28,6 +28,7 @@
+--- a/ath10k-6.9/core.c
++++ b/ath10k-6.9/core.c
+@@ -29,6 +29,7 @@
  #include "testmode.h"
  #include "wmi-ops.h"
  #include "coredump.h"
@@ -71,7 +71,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  
  /* Disable ath10k-ct DBGLOG output by default */
  unsigned int ath10k_debug_mask = ATH10K_DBG_NO_DBGLOG;
-@@ -80,6 +81,7 @@ static const struct ath10k_hw_params ath
+@@ -81,6 +82,7 @@ static const struct ath10k_hw_params ath
                .name = "qca988x hw2.0",
                .patch_load_addr = QCA988X_HW_2_0_PATCH_LOAD_ADDR,
                .uart_pin = 7,
@@ -79,7 +79,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
                .cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_ALL,
                .otp_exe_param = 0,
                .channel_counters_freq_hz = 88000,
-@@ -120,6 +122,7 @@ static const struct ath10k_hw_params ath
+@@ -122,6 +124,7 @@ static const struct ath10k_hw_params ath
                .name = "qca988x hw2.0 ubiquiti",
                .patch_load_addr = QCA988X_HW_2_0_PATCH_LOAD_ADDR,
                .uart_pin = 7,
@@ -87,7 +87,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
                .cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_ALL,
                .otp_exe_param = 0,
                .channel_counters_freq_hz = 88000,
-@@ -161,6 +164,7 @@ static const struct ath10k_hw_params ath
+@@ -164,6 +167,7 @@ static const struct ath10k_hw_params ath
                .name = "qca9887 hw1.0",
                .patch_load_addr = QCA9887_HW_1_0_PATCH_LOAD_ADDR,
                .uart_pin = 7,
@@ -95,7 +95,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
                .cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_ALL,
                .otp_exe_param = 0,
                .channel_counters_freq_hz = 88000,
-@@ -202,6 +206,7 @@ static const struct ath10k_hw_params ath
+@@ -206,6 +210,7 @@ static const struct ath10k_hw_params ath
                .name = "qca6174 hw3.2 sdio",
                .patch_load_addr = QCA6174_HW_3_0_PATCH_LOAD_ADDR,
                .uart_pin = 19,
@@ -103,7 +103,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
                .otp_exe_param = 0,
                .channel_counters_freq_hz = 88000,
                .max_probe_resp_desc_thres = 0,
-@@ -238,6 +243,7 @@ static const struct ath10k_hw_params ath
+@@ -243,6 +248,7 @@ static const struct ath10k_hw_params ath
                .name = "qca6164 hw2.1",
                .patch_load_addr = QCA6174_HW_2_1_PATCH_LOAD_ADDR,
                .uart_pin = 6,
@@ -111,7 +111,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
                .otp_exe_param = 0,
                .channel_counters_freq_hz = 88000,
                .max_probe_resp_desc_thres = 0,
-@@ -278,6 +284,7 @@ static const struct ath10k_hw_params ath
+@@ -284,6 +290,7 @@ static const struct ath10k_hw_params ath
                .name = "qca6174 hw2.1",
                .patch_load_addr = QCA6174_HW_2_1_PATCH_LOAD_ADDR,
                .uart_pin = 6,
@@ -119,7 +119,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
                .otp_exe_param = 0,
                .channel_counters_freq_hz = 88000,
                .max_probe_resp_desc_thres = 0,
-@@ -318,6 +325,7 @@ static const struct ath10k_hw_params ath
+@@ -325,6 +332,7 @@ static const struct ath10k_hw_params ath
                .name = "qca6174 hw3.0",
                .patch_load_addr = QCA6174_HW_3_0_PATCH_LOAD_ADDR,
                .uart_pin = 6,
@@ -127,7 +127,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
                .otp_exe_param = 0,
                .channel_counters_freq_hz = 88000,
                .max_probe_resp_desc_thres = 0,
-@@ -358,6 +366,7 @@ static const struct ath10k_hw_params ath
+@@ -366,6 +374,7 @@ static const struct ath10k_hw_params ath
                .name = "qca6174 hw3.2",
                .patch_load_addr = QCA6174_HW_3_0_PATCH_LOAD_ADDR,
                .uart_pin = 6,
@@ -135,7 +135,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
                .otp_exe_param = 0,
                .channel_counters_freq_hz = 88000,
                .max_probe_resp_desc_thres = 0,
-@@ -402,6 +411,7 @@ static const struct ath10k_hw_params ath
+@@ -411,6 +420,7 @@ static const struct ath10k_hw_params ath
                .name = "qca99x0 hw2.0",
                .patch_load_addr = QCA99X0_HW_2_0_PATCH_LOAD_ADDR,
                .uart_pin = 7,
@@ -143,7 +143,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
                .otp_exe_param = 0x00000700,
                .continuous_frag_desc = true,
                .cck_rate_map_rev2 = true,
-@@ -448,6 +458,7 @@ static const struct ath10k_hw_params ath
+@@ -458,6 +468,7 @@ static const struct ath10k_hw_params ath
                .name = "qca9984/qca9994 hw1.0",
                .patch_load_addr = QCA9984_HW_1_0_PATCH_LOAD_ADDR,
                .uart_pin = 7,
@@ -151,7 +151,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
                .cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_EACH,
                .otp_exe_param = 0x00000700,
                .continuous_frag_desc = true,
-@@ -501,6 +512,7 @@ static const struct ath10k_hw_params ath
+@@ -512,6 +523,7 @@ static const struct ath10k_hw_params ath
                .name = "qca9888 hw2.0",
                .patch_load_addr = QCA9888_HW_2_0_PATCH_LOAD_ADDR,
                .uart_pin = 7,
@@ -159,7 +159,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
                .cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_EACH,
                .otp_exe_param = 0x00000700,
                .continuous_frag_desc = true,
-@@ -551,6 +563,7 @@ static const struct ath10k_hw_params ath
+@@ -563,6 +575,7 @@ static const struct ath10k_hw_params ath
                .name = "qca9377 hw1.0",
                .patch_load_addr = QCA9377_HW_1_0_PATCH_LOAD_ADDR,
                .uart_pin = 6,
@@ -167,7 +167,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
                .otp_exe_param = 0,
                .channel_counters_freq_hz = 88000,
                .max_probe_resp_desc_thres = 0,
-@@ -591,6 +604,7 @@ static const struct ath10k_hw_params ath
+@@ -604,6 +617,7 @@ static const struct ath10k_hw_params ath
                .name = "qca9377 hw1.1",
                .patch_load_addr = QCA9377_HW_1_0_PATCH_LOAD_ADDR,
                .uart_pin = 6,
@@ -175,7 +175,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
                .otp_exe_param = 0,
                .channel_counters_freq_hz = 88000,
                .max_probe_resp_desc_thres = 0,
-@@ -633,6 +647,7 @@ static const struct ath10k_hw_params ath
+@@ -647,6 +661,7 @@ static const struct ath10k_hw_params ath
                .name = "qca9377 hw1.1 sdio",
                .patch_load_addr = QCA9377_HW_1_0_PATCH_LOAD_ADDR,
                .uart_pin = 19,
@@ -183,7 +183,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
                .otp_exe_param = 0,
                .channel_counters_freq_hz = 88000,
                .max_probe_resp_desc_thres = 0,
-@@ -666,6 +681,7 @@ static const struct ath10k_hw_params ath
+@@ -681,6 +696,7 @@ static const struct ath10k_hw_params ath
                .name = "qca4019 hw1.0",
                .patch_load_addr = QCA4019_HW_1_0_PATCH_LOAD_ADDR,
                .uart_pin = 7,
@@ -191,7 +191,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
                .cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_EACH,
                .otp_exe_param = 0x0010000,
                .continuous_frag_desc = true,
-@@ -711,6 +727,7 @@ static const struct ath10k_hw_params ath
+@@ -727,6 +743,7 @@ static const struct ath10k_hw_params ath
                .dev_id = 0,
                .bus = ATH10K_BUS_SNOC,
                .name = "wcn3990 hw1.0",
@@ -199,7 +199,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
                .continuous_frag_desc = true,
                .tx_chain_mask = 0x7,
                .rx_chain_mask = 0x7,
-@@ -4071,6 +4088,10 @@ int ath10k_core_start(struct ath10k *ar,
+@@ -4091,6 +4108,10 @@ int ath10k_core_start(struct ath10k *ar,
                        ath10k_wmi_check_apply_board_power_ctl_table(ar);
        }
  
@@ -210,7 +210,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
        return 0;
  
  err_hif_stop:
-@@ -4332,9 +4353,18 @@ static void ath10k_core_register_work(st
+@@ -4352,9 +4373,18 @@ static void ath10k_core_register_work(st
                goto err_spectral_destroy;
        }
  
@@ -229,7 +229,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  err_spectral_destroy:
        ath10k_spectral_destroy(ar);
  err_debug_destroy:
-@@ -4394,6 +4424,8 @@ void ath10k_core_unregister(struct ath10
+@@ -4414,6 +4444,8 @@ void ath10k_core_unregister(struct ath10
        if (!test_bit(ATH10K_FLAG_CORE_REGISTERED, &ar->dev_flags))
                return;
  
@@ -238,9 +238,9 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
        ath10k_thermal_unregister(ar);
        /* Stop spectral before unregistering from mac80211 to remove the
         * relayfs debugfs file cleanly. Otherwise the parent debugfs tree
---- a/ath10k-6.7/core.h
-+++ b/ath10k-6.7/core.h
-@@ -14,6 +14,7 @@
+--- a/ath10k-6.9/core.h
++++ b/ath10k-6.9/core.h
+@@ -15,6 +15,7 @@
  #include <linux/pci.h>
  #include <linux/uuid.h>
  #include <linux/time.h>
@@ -248,7 +248,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  
  #include "htt.h"
  #include "htc.h"
-@@ -1589,6 +1590,13 @@ struct ath10k {
+@@ -1590,6 +1591,13 @@ struct ath10k {
        } testmode;
  
        struct {
@@ -262,9 +262,9 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
                /* protected by data_lock */
                u32 rx_crc_err_drop;
                u32 fw_crash_counter;
---- a/ath10k-6.7/hw.h
-+++ b/ath10k-6.7/hw.h
-@@ -523,6 +523,7 @@ struct ath10k_hw_params {
+--- a/ath10k-6.9/hw.h
++++ b/ath10k-6.9/hw.h
+@@ -525,6 +525,7 @@ struct ath10k_hw_params {
        const char *name;
        u32 patch_load_addr;
        int uart_pin;
@@ -273,7 +273,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  
        /* Type of hw cycle counter wraparound logic, for more info
 --- /dev/null
-+++ b/ath10k-6.7/leds.c
++++ b/ath10k-6.9/leds.c
 @@ -0,0 +1,90 @@
 +// SPDX-License-Identifier: ISC
 +/*
@@ -366,7 +366,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
 +}
 +
 --- /dev/null
-+++ b/ath10k-6.7/leds.h
++++ b/ath10k-6.9/leds.h
 @@ -0,0 +1,34 @@
 +/* SPDX-License-Identifier: ISC */
 +/*
@@ -402,9 +402,9 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
 +
 +#endif
 +#endif /* _LEDS_H_ */
---- a/ath10k-6.7/mac.c
-+++ b/ath10k-6.7/mac.c
-@@ -25,6 +25,7 @@
+--- a/ath10k-6.9/mac.c
++++ b/ath10k-6.9/mac.c
+@@ -26,6 +26,7 @@
  #include "wmi-tlv.h"
  #include "wmi-ops.h"
  #include "wow.h"
@@ -412,8 +412,8 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  
  /*********/
  /* Rates */
---- a/ath10k-6.7/wmi-ops.h
-+++ b/ath10k-6.7/wmi-ops.h
+--- a/ath10k-6.9/wmi-ops.h
++++ b/ath10k-6.9/wmi-ops.h
 @@ -228,7 +228,10 @@ struct wmi_ops {
                         const struct wmi_bb_timing_cfg_arg *arg);
        struct sk_buff *(*gen_per_peer_per_tid_cfg)(struct ath10k *ar,
@@ -461,9 +461,9 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  static inline int
  ath10k_wmi_dbglog_cfg(struct ath10k *ar, u64 module_enable, u32 log_level)
  {
---- a/ath10k-6.7/wmi-tlv.c
-+++ b/ath10k-6.7/wmi-tlv.c
-@@ -4601,6 +4601,8 @@ static const struct wmi_ops wmi_tlv_ops
+--- a/ath10k-6.9/wmi-tlv.c
++++ b/ath10k-6.9/wmi-tlv.c
+@@ -4606,6 +4606,8 @@ static const struct wmi_ops wmi_tlv_ops
        .gen_echo = ath10k_wmi_tlv_op_gen_echo,
        .gen_vdev_spectral_conf = ath10k_wmi_tlv_op_gen_vdev_spectral_conf,
        .gen_vdev_spectral_enable = ath10k_wmi_tlv_op_gen_vdev_spectral_enable,
@@ -472,9 +472,9 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  };
  
  static const struct wmi_peer_flags_map wmi_tlv_peer_flags_map = {
---- a/ath10k-6.7/wmi.c
-+++ b/ath10k-6.7/wmi.c
-@@ -8446,6 +8446,49 @@ ath10k_wmi_op_gen_peer_set_param(struct
+--- a/ath10k-6.9/wmi.c
++++ b/ath10k-6.9/wmi.c
+@@ -8467,6 +8467,49 @@ ath10k_wmi_op_gen_peer_set_param(struct
        return skb;
  }
  
@@ -524,7 +524,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  static struct sk_buff *
  ath10k_wmi_op_gen_set_psmode(struct ath10k *ar, u32 vdev_id,
                             enum wmi_sta_ps_mode psmode)
-@@ -10255,6 +10298,9 @@ static const struct wmi_ops wmi_ops = {
+@@ -10274,6 +10317,9 @@ static const struct wmi_ops wmi_ops = {
        .fw_stats_fill = ath10k_wmi_main_op_fw_stats_fill,
        .get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
        .gen_echo = ath10k_wmi_op_gen_echo,
@@ -534,7 +534,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
        /* .gen_bcn_tmpl not implemented */
        /* .gen_prb_tmpl not implemented */
        /* .gen_p2p_go_bcn_ie not implemented */
-@@ -10325,6 +10371,8 @@ static const struct wmi_ops wmi_10_1_ops
+@@ -10344,6 +10390,8 @@ static const struct wmi_ops wmi_10_1_ops
        .fw_stats_fill = ath10k_wmi_10x_op_fw_stats_fill,
        .get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
        .gen_echo = ath10k_wmi_op_gen_echo,
@@ -543,7 +543,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
        /* .gen_bcn_tmpl not implemented */
        /* .gen_prb_tmpl not implemented */
        /* .gen_p2p_go_bcn_ie not implemented */
-@@ -10404,6 +10452,8 @@ static const struct wmi_ops wmi_10_2_ops
+@@ -10423,6 +10471,8 @@ static const struct wmi_ops wmi_10_2_ops
        .gen_delba_send = ath10k_wmi_op_gen_delba_send,
        .fw_stats_fill = ath10k_wmi_10x_op_fw_stats_fill,
        .get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
@@ -552,7 +552,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
        /* .gen_pdev_enable_adaptive_cca not implemented */
  };
  
-@@ -10475,6 +10525,8 @@ static const struct wmi_ops wmi_10_2_4_o
+@@ -10494,6 +10544,8 @@ static const struct wmi_ops wmi_10_2_4_o
                ath10k_wmi_op_gen_pdev_enable_adaptive_cca,
        .get_vdev_subtype = ath10k_wmi_10_2_4_op_get_vdev_subtype,
        .gen_bb_timing = ath10k_wmi_10_2_4_op_gen_bb_timing,
@@ -561,7 +561,7 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
        /* .gen_bcn_tmpl not implemented */
        /* .gen_prb_tmpl not implemented */
        /* .gen_p2p_go_bcn_ie not implemented */
-@@ -10557,6 +10609,8 @@ static const struct wmi_ops wmi_10_4_ops
+@@ -10576,6 +10628,8 @@ static const struct wmi_ops wmi_10_4_ops
        .gen_pdev_bss_chan_info_req = ath10k_wmi_10_2_op_gen_pdev_bss_chan_info,
        .gen_echo = ath10k_wmi_op_gen_echo,
        .gen_pdev_get_tpc_config = ath10k_wmi_10_2_4_op_gen_pdev_get_tpc_config,
@@ -570,9 +570,9 @@ Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
  };
  
  int ath10k_wmi_attach(struct ath10k *ar)
---- a/ath10k-6.7/wmi.h
-+++ b/ath10k-6.7/wmi.h
-@@ -3133,6 +3133,41 @@ enum wmi_10_4_feature_mask {
+--- a/ath10k-6.9/wmi.h
++++ b/ath10k-6.9/wmi.h
+@@ -3137,6 +3137,41 @@ enum wmi_10_4_feature_mask {
  
  };
  
index 39b7f645d757ffe1f282014d3ccc66dcecbb69aa..9bd07a24a6df25ed6916a14579ce9e116ccd0e73 100644 (file)
@@ -14,9 +14,9 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
  ath10k-6.7/mac.c  | 2 +-
  3 files changed, 6 insertions(+), 4 deletions(-)
 
---- a/ath10k-6.7/core.h
-+++ b/ath10k-6.7/core.h
-@@ -1704,6 +1704,10 @@ struct ath10k {
+--- a/ath10k-6.9/core.h
++++ b/ath10k-6.9/core.h
+@@ -1705,6 +1705,10 @@ struct ath10k {
        u8 csi_data[4096];
        u16 csi_data_len;
  
@@ -27,8 +27,8 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
        /* must be last */
        u8 drv_priv[] __aligned(sizeof(void *));
  };
---- a/ath10k-6.7/leds.c
-+++ b/ath10k-6.7/leds.c
+--- a/ath10k-6.9/leds.c
++++ b/ath10k-6.9/leds.c
 @@ -70,7 +70,7 @@ int ath10k_leds_register(struct ath10k *
  
        ar->leds.cdev.name = ar->leds.label;
@@ -38,9 +38,9 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
  
        ret = led_classdev_register(wiphy_dev(ar->hw->wiphy), &ar->leds.cdev);
        if (ret)
---- a/ath10k-6.7/mac.c
-+++ b/ath10k-6.7/mac.c
-@@ -11622,7 +11622,7 @@ int ath10k_mac_register(struct ath10k *a
+--- a/ath10k-6.9/mac.c
++++ b/ath10k-6.9/mac.c
+@@ -11631,7 +11631,7 @@ int ath10k_mac_register(struct ath10k *a
        ar->hw->weight_multiplier = ATH10K_AIRTIME_WEIGHT_MULTIPLIER;
  
  #ifdef CPTCFG_MAC80211_LEDS
index 1797b16dcf20441d9ba8f73bbd4a1ee1244d07c5..122716c24dbf6eb0d15f12e0fd744609362020f6 100644 (file)
@@ -1,6 +1,6 @@
---- a/ath10k-6.7/wmi.h
-+++ b/ath10k-6.7/wmi.h
-@@ -6341,7 +6341,7 @@ struct qca9880_set_ctl_table_cmd {
+--- a/ath10k-6.9/wmi.h
++++ b/ath10k-6.9/wmi.h
+@@ -6310,7 +6310,7 @@ struct qca9880_set_ctl_table_cmd {
        __le32 ctl_len; /* in bytes.  This may be ignored in firmware,
                         * make sure ctl_info data is sizeof(qca9880_power_ctl) */
        /** ctl array (len adjusted to  number of words) */
index 5fb70ab5c712e29734965038855a7513e4664967..c1de78de98cdced054bcd2b75cc70b5a35304d4b 100644 (file)
@@ -1,6 +1,6 @@
---- a/ath10k-6.7/htt.h
-+++ b/ath10k-6.7/htt.h
-@@ -237,7 +237,11 @@ enum htt_rx_ring_flags {
+--- a/ath10k-6.9/htt.h
++++ b/ath10k-6.9/htt.h
+@@ -238,7 +238,11 @@ enum htt_rx_ring_flags {
  };
  
  #define HTT_RX_RING_SIZE_MIN 128
index eceb66c3bb8aace6d952a7893d1dd0e84d6d7286..3dcbda371540259a23abbb36b14fe236c6510ab9 100644 (file)
@@ -1,6 +1,6 @@
---- a/ath10k-6.7/pci.c
-+++ b/ath10k-6.7/pci.c
-@@ -131,7 +131,11 @@ static const struct ce_attr pci_host_ce_
+--- a/ath10k-6.9/pci.c
++++ b/ath10k-6.9/pci.c
+@@ -132,7 +132,11 @@ static const struct ce_attr pci_host_ce_
                .flags = CE_ATTR_FLAGS,
                .src_nentries = 0,
                .src_sz_max = 2048,
@@ -12,7 +12,7 @@
                .recv_cb = ath10k_pci_htt_htc_rx_cb,
        },
  
-@@ -140,7 +144,11 @@ static const struct ce_attr pci_host_ce_
+@@ -141,7 +145,11 @@ static const struct ce_attr pci_host_ce_
                .flags = CE_ATTR_FLAGS,
                .src_nentries = 0,
                .src_sz_max = 2048,
@@ -24,7 +24,7 @@
                .recv_cb = ath10k_pci_htc_rx_cb,
        },
  
-@@ -167,7 +175,11 @@ static const struct ce_attr pci_host_ce_
+@@ -168,7 +176,11 @@ static const struct ce_attr pci_host_ce_
                .flags = CE_ATTR_FLAGS,
                .src_nentries = 0,
                .src_sz_max = 512,
@@ -36,7 +36,7 @@
                .recv_cb = ath10k_pci_htt_rx_cb,
        },
  
-@@ -192,7 +204,11 @@ static const struct ce_attr pci_host_ce_
+@@ -193,7 +205,11 @@ static const struct ce_attr pci_host_ce_
                .flags = CE_ATTR_FLAGS,
                .src_nentries = 0,
                .src_sz_max = 2048,
index 165f1803883e34a6d60877a0109b0bd2416c5bbb..974072fb9a7aa48fda961f4bbfc674c9c28581c1 100644 (file)
@@ -13,12 +13,12 @@ own loss detection mechanism.
 
 Signed-off-by: David Bauer <mail@david-bauer.net>
 ---
- ath10k-6.7/mac.c | 1 -
+ ath10k-6.9/mac.c | 1 -
  1 file changed, 1 deletion(-)
 
---- a/ath10k-6.7/mac.c
-+++ b/ath10k-6.7/mac.c
-@@ -11311,7 +11311,6 @@ int ath10k_mac_register(struct ath10k *a
+--- a/ath10k-6.9/mac.c
++++ b/ath10k-6.9/mac.c
+@@ -11316,7 +11316,6 @@ int ath10k_mac_register(struct ath10k *a
        ieee80211_hw_set(ar->hw, CHANCTX_STA_CSA);
        ieee80211_hw_set(ar->hw, QUEUE_CONTROL);
        ieee80211_hw_set(ar->hw, SUPPORTS_TX_FRAG);