Signed-off-by: Kalle Valo <quic_kvalo@quicinc.com>
Link: https://msgid.link/20230611080505.17393-1-ansuelsmth@gmail.com
---
- ath10k-6.7/Kconfig | 6 ++
- ath10k-6.7/Makefile | 1 +
- ath10k-6.7/core.c | 32 ++++++++
- ath10k-6.7/core.h | 8 ++
- ath10k-6.7/hw.h | 1 +
- ath10k-6.7/leds.c | 90 +++++++++++++++++++++++
- ath10k-6.7/leds.h | 34 +++++++++
- ath10k-6.7/mac.c | 1 +
- ath10k-6.7/wmi-ops.h | 32 ++++++++
- ath10k-6.7/wmi-tlv.c | 2 +
- ath10k-6.7/wmi.c | 54 ++++++++++++++
- ath10k-6.7/wmi.h | 35 +++++++++
+ ath10k-6.9/Kconfig | 6 ++
+ ath10k-6.9/Makefile | 1 +
+ ath10k-6.9/core.c | 32 ++++++++
+ ath10k-6.9/core.h | 8 ++
+ ath10k-6.9/hw.h | 1 +
+ ath10k-6.9/leds.c | 90 +++++++++++++++++++++++
+ ath10k-6.9/leds.h | 34 +++++++++
+ ath10k-6.9/mac.c | 1 +
+ ath10k-6.9/wmi-ops.h | 32 ++++++++
+ ath10k-6.9/wmi-tlv.c | 2 +
+ ath10k-6.9/wmi.c | 54 ++++++++++++++
+ ath10k-6.9/wmi.h | 35 +++++++++
12 files changed, 296 insertions(+)
- create mode 100644 ath10k-6.7/leds.c
- create mode 100644 ath10k-6.7/leds.h
+ create mode 100644 ath10k-6.9/leds.c
+ create mode 100644 ath10k-6.9/leds.h
---- a/ath10k-6.7/Kconfig
-+++ b/ath10k-6.7/Kconfig
-@@ -67,6 +67,12 @@ config ATH10K_DEBUGFS
+--- a/ath10k-6.9/Kconfig
++++ b/ath10k-6.9/Kconfig
+@@ -68,6 +68,12 @@ config ATH10K_DEBUGFS
If unsure, say Y to make it easier to debug problems.
config ATH10K_SPECTRAL
bool "Atheros ath10k spectral scan support"
depends on ATH10K_DEBUGFS
---- a/ath10k-6.7/Makefile
-+++ b/ath10k-6.7/Makefile
+--- a/ath10k-6.9/Makefile
++++ b/ath10k-6.9/Makefile
@@ -20,6 +20,7 @@ ath10k_core-$(CONFIG_ATH10K_SPECTRAL) +=
ath10k_core-$(CONFIG_NL80211_TESTMODE) += testmode.o
ath10k_core-$(CONFIG_ATH10K_TRACING) += trace.o
ath10k_core-$(CONFIG_MAC80211_DEBUGFS) += debugfs_sta.o
ath10k_core-$(CONFIG_PM) += wow.o
ath10k_core-$(CONFIG_ATH10K_CE) += ce.o
---- a/ath10k-6.7/core.c
-+++ b/ath10k-6.7/core.c
-@@ -28,6 +28,7 @@
+--- a/ath10k-6.9/core.c
++++ b/ath10k-6.9/core.c
+@@ -29,6 +29,7 @@
#include "testmode.h"
#include "wmi-ops.h"
#include "coredump.h"
/* Disable ath10k-ct DBGLOG output by default */
unsigned int ath10k_debug_mask = ATH10K_DBG_NO_DBGLOG;
-@@ -80,6 +81,7 @@ static const struct ath10k_hw_params ath
+@@ -81,6 +82,7 @@ static const struct ath10k_hw_params ath
.name = "qca988x hw2.0",
.patch_load_addr = QCA988X_HW_2_0_PATCH_LOAD_ADDR,
.uart_pin = 7,
.cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_ALL,
.otp_exe_param = 0,
.channel_counters_freq_hz = 88000,
-@@ -120,6 +122,7 @@ static const struct ath10k_hw_params ath
+@@ -122,6 +124,7 @@ static const struct ath10k_hw_params ath
.name = "qca988x hw2.0 ubiquiti",
.patch_load_addr = QCA988X_HW_2_0_PATCH_LOAD_ADDR,
.uart_pin = 7,
.cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_ALL,
.otp_exe_param = 0,
.channel_counters_freq_hz = 88000,
-@@ -161,6 +164,7 @@ static const struct ath10k_hw_params ath
+@@ -164,6 +167,7 @@ static const struct ath10k_hw_params ath
.name = "qca9887 hw1.0",
.patch_load_addr = QCA9887_HW_1_0_PATCH_LOAD_ADDR,
.uart_pin = 7,
.cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_ALL,
.otp_exe_param = 0,
.channel_counters_freq_hz = 88000,
-@@ -202,6 +206,7 @@ static const struct ath10k_hw_params ath
+@@ -206,6 +210,7 @@ static const struct ath10k_hw_params ath
.name = "qca6174 hw3.2 sdio",
.patch_load_addr = QCA6174_HW_3_0_PATCH_LOAD_ADDR,
.uart_pin = 19,
.otp_exe_param = 0,
.channel_counters_freq_hz = 88000,
.max_probe_resp_desc_thres = 0,
-@@ -238,6 +243,7 @@ static const struct ath10k_hw_params ath
+@@ -243,6 +248,7 @@ static const struct ath10k_hw_params ath
.name = "qca6164 hw2.1",
.patch_load_addr = QCA6174_HW_2_1_PATCH_LOAD_ADDR,
.uart_pin = 6,
.otp_exe_param = 0,
.channel_counters_freq_hz = 88000,
.max_probe_resp_desc_thres = 0,
-@@ -278,6 +284,7 @@ static const struct ath10k_hw_params ath
+@@ -284,6 +290,7 @@ static const struct ath10k_hw_params ath
.name = "qca6174 hw2.1",
.patch_load_addr = QCA6174_HW_2_1_PATCH_LOAD_ADDR,
.uart_pin = 6,
.otp_exe_param = 0,
.channel_counters_freq_hz = 88000,
.max_probe_resp_desc_thres = 0,
-@@ -318,6 +325,7 @@ static const struct ath10k_hw_params ath
+@@ -325,6 +332,7 @@ static const struct ath10k_hw_params ath
.name = "qca6174 hw3.0",
.patch_load_addr = QCA6174_HW_3_0_PATCH_LOAD_ADDR,
.uart_pin = 6,
.otp_exe_param = 0,
.channel_counters_freq_hz = 88000,
.max_probe_resp_desc_thres = 0,
-@@ -358,6 +366,7 @@ static const struct ath10k_hw_params ath
+@@ -366,6 +374,7 @@ static const struct ath10k_hw_params ath
.name = "qca6174 hw3.2",
.patch_load_addr = QCA6174_HW_3_0_PATCH_LOAD_ADDR,
.uart_pin = 6,
.otp_exe_param = 0,
.channel_counters_freq_hz = 88000,
.max_probe_resp_desc_thres = 0,
-@@ -402,6 +411,7 @@ static const struct ath10k_hw_params ath
+@@ -411,6 +420,7 @@ static const struct ath10k_hw_params ath
.name = "qca99x0 hw2.0",
.patch_load_addr = QCA99X0_HW_2_0_PATCH_LOAD_ADDR,
.uart_pin = 7,
.otp_exe_param = 0x00000700,
.continuous_frag_desc = true,
.cck_rate_map_rev2 = true,
-@@ -448,6 +458,7 @@ static const struct ath10k_hw_params ath
+@@ -458,6 +468,7 @@ static const struct ath10k_hw_params ath
.name = "qca9984/qca9994 hw1.0",
.patch_load_addr = QCA9984_HW_1_0_PATCH_LOAD_ADDR,
.uart_pin = 7,
.cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_EACH,
.otp_exe_param = 0x00000700,
.continuous_frag_desc = true,
-@@ -501,6 +512,7 @@ static const struct ath10k_hw_params ath
+@@ -512,6 +523,7 @@ static const struct ath10k_hw_params ath
.name = "qca9888 hw2.0",
.patch_load_addr = QCA9888_HW_2_0_PATCH_LOAD_ADDR,
.uart_pin = 7,
.cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_EACH,
.otp_exe_param = 0x00000700,
.continuous_frag_desc = true,
-@@ -551,6 +563,7 @@ static const struct ath10k_hw_params ath
+@@ -563,6 +575,7 @@ static const struct ath10k_hw_params ath
.name = "qca9377 hw1.0",
.patch_load_addr = QCA9377_HW_1_0_PATCH_LOAD_ADDR,
.uart_pin = 6,
.otp_exe_param = 0,
.channel_counters_freq_hz = 88000,
.max_probe_resp_desc_thres = 0,
-@@ -591,6 +604,7 @@ static const struct ath10k_hw_params ath
+@@ -604,6 +617,7 @@ static const struct ath10k_hw_params ath
.name = "qca9377 hw1.1",
.patch_load_addr = QCA9377_HW_1_0_PATCH_LOAD_ADDR,
.uart_pin = 6,
.otp_exe_param = 0,
.channel_counters_freq_hz = 88000,
.max_probe_resp_desc_thres = 0,
-@@ -633,6 +647,7 @@ static const struct ath10k_hw_params ath
+@@ -647,6 +661,7 @@ static const struct ath10k_hw_params ath
.name = "qca9377 hw1.1 sdio",
.patch_load_addr = QCA9377_HW_1_0_PATCH_LOAD_ADDR,
.uart_pin = 19,
.otp_exe_param = 0,
.channel_counters_freq_hz = 88000,
.max_probe_resp_desc_thres = 0,
-@@ -666,6 +681,7 @@ static const struct ath10k_hw_params ath
+@@ -681,6 +696,7 @@ static const struct ath10k_hw_params ath
.name = "qca4019 hw1.0",
.patch_load_addr = QCA4019_HW_1_0_PATCH_LOAD_ADDR,
.uart_pin = 7,
.cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_EACH,
.otp_exe_param = 0x0010000,
.continuous_frag_desc = true,
-@@ -711,6 +727,7 @@ static const struct ath10k_hw_params ath
+@@ -727,6 +743,7 @@ static const struct ath10k_hw_params ath
.dev_id = 0,
.bus = ATH10K_BUS_SNOC,
.name = "wcn3990 hw1.0",
.continuous_frag_desc = true,
.tx_chain_mask = 0x7,
.rx_chain_mask = 0x7,
-@@ -4071,6 +4088,10 @@ int ath10k_core_start(struct ath10k *ar,
+@@ -4091,6 +4108,10 @@ int ath10k_core_start(struct ath10k *ar,
ath10k_wmi_check_apply_board_power_ctl_table(ar);
}
return 0;
err_hif_stop:
-@@ -4332,9 +4353,18 @@ static void ath10k_core_register_work(st
+@@ -4352,9 +4373,18 @@ static void ath10k_core_register_work(st
goto err_spectral_destroy;
}
err_spectral_destroy:
ath10k_spectral_destroy(ar);
err_debug_destroy:
-@@ -4394,6 +4424,8 @@ void ath10k_core_unregister(struct ath10
+@@ -4414,6 +4444,8 @@ void ath10k_core_unregister(struct ath10
if (!test_bit(ATH10K_FLAG_CORE_REGISTERED, &ar->dev_flags))
return;
ath10k_thermal_unregister(ar);
/* Stop spectral before unregistering from mac80211 to remove the
* relayfs debugfs file cleanly. Otherwise the parent debugfs tree
---- a/ath10k-6.7/core.h
-+++ b/ath10k-6.7/core.h
-@@ -14,6 +14,7 @@
+--- a/ath10k-6.9/core.h
++++ b/ath10k-6.9/core.h
+@@ -15,6 +15,7 @@
#include <linux/pci.h>
#include <linux/uuid.h>
#include <linux/time.h>
#include "htt.h"
#include "htc.h"
-@@ -1589,6 +1590,13 @@ struct ath10k {
+@@ -1590,6 +1591,13 @@ struct ath10k {
} testmode;
struct {
/* protected by data_lock */
u32 rx_crc_err_drop;
u32 fw_crash_counter;
---- a/ath10k-6.7/hw.h
-+++ b/ath10k-6.7/hw.h
-@@ -523,6 +523,7 @@ struct ath10k_hw_params {
+--- a/ath10k-6.9/hw.h
++++ b/ath10k-6.9/hw.h
+@@ -525,6 +525,7 @@ struct ath10k_hw_params {
const char *name;
u32 patch_load_addr;
int uart_pin;
/* Type of hw cycle counter wraparound logic, for more info
--- /dev/null
-+++ b/ath10k-6.7/leds.c
++++ b/ath10k-6.9/leds.c
@@ -0,0 +1,90 @@
+// SPDX-License-Identifier: ISC
+/*
+}
+
--- /dev/null
-+++ b/ath10k-6.7/leds.h
++++ b/ath10k-6.9/leds.h
@@ -0,0 +1,34 @@
+/* SPDX-License-Identifier: ISC */
+/*
+
+#endif
+#endif /* _LEDS_H_ */
---- a/ath10k-6.7/mac.c
-+++ b/ath10k-6.7/mac.c
-@@ -25,6 +25,7 @@
+--- a/ath10k-6.9/mac.c
++++ b/ath10k-6.9/mac.c
+@@ -26,6 +26,7 @@
#include "wmi-tlv.h"
#include "wmi-ops.h"
#include "wow.h"
/*********/
/* Rates */
---- a/ath10k-6.7/wmi-ops.h
-+++ b/ath10k-6.7/wmi-ops.h
+--- a/ath10k-6.9/wmi-ops.h
++++ b/ath10k-6.9/wmi-ops.h
@@ -228,7 +228,10 @@ struct wmi_ops {
const struct wmi_bb_timing_cfg_arg *arg);
struct sk_buff *(*gen_per_peer_per_tid_cfg)(struct ath10k *ar,
static inline int
ath10k_wmi_dbglog_cfg(struct ath10k *ar, u64 module_enable, u32 log_level)
{
---- a/ath10k-6.7/wmi-tlv.c
-+++ b/ath10k-6.7/wmi-tlv.c
-@@ -4601,6 +4601,8 @@ static const struct wmi_ops wmi_tlv_ops
+--- a/ath10k-6.9/wmi-tlv.c
++++ b/ath10k-6.9/wmi-tlv.c
+@@ -4606,6 +4606,8 @@ static const struct wmi_ops wmi_tlv_ops
.gen_echo = ath10k_wmi_tlv_op_gen_echo,
.gen_vdev_spectral_conf = ath10k_wmi_tlv_op_gen_vdev_spectral_conf,
.gen_vdev_spectral_enable = ath10k_wmi_tlv_op_gen_vdev_spectral_enable,
};
static const struct wmi_peer_flags_map wmi_tlv_peer_flags_map = {
---- a/ath10k-6.7/wmi.c
-+++ b/ath10k-6.7/wmi.c
-@@ -8446,6 +8446,49 @@ ath10k_wmi_op_gen_peer_set_param(struct
+--- a/ath10k-6.9/wmi.c
++++ b/ath10k-6.9/wmi.c
+@@ -8467,6 +8467,49 @@ ath10k_wmi_op_gen_peer_set_param(struct
return skb;
}
static struct sk_buff *
ath10k_wmi_op_gen_set_psmode(struct ath10k *ar, u32 vdev_id,
enum wmi_sta_ps_mode psmode)
-@@ -10255,6 +10298,9 @@ static const struct wmi_ops wmi_ops = {
+@@ -10274,6 +10317,9 @@ static const struct wmi_ops wmi_ops = {
.fw_stats_fill = ath10k_wmi_main_op_fw_stats_fill,
.get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
.gen_echo = ath10k_wmi_op_gen_echo,
/* .gen_bcn_tmpl not implemented */
/* .gen_prb_tmpl not implemented */
/* .gen_p2p_go_bcn_ie not implemented */
-@@ -10325,6 +10371,8 @@ static const struct wmi_ops wmi_10_1_ops
+@@ -10344,6 +10390,8 @@ static const struct wmi_ops wmi_10_1_ops
.fw_stats_fill = ath10k_wmi_10x_op_fw_stats_fill,
.get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
.gen_echo = ath10k_wmi_op_gen_echo,
/* .gen_bcn_tmpl not implemented */
/* .gen_prb_tmpl not implemented */
/* .gen_p2p_go_bcn_ie not implemented */
-@@ -10404,6 +10452,8 @@ static const struct wmi_ops wmi_10_2_ops
+@@ -10423,6 +10471,8 @@ static const struct wmi_ops wmi_10_2_ops
.gen_delba_send = ath10k_wmi_op_gen_delba_send,
.fw_stats_fill = ath10k_wmi_10x_op_fw_stats_fill,
.get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
/* .gen_pdev_enable_adaptive_cca not implemented */
};
-@@ -10475,6 +10525,8 @@ static const struct wmi_ops wmi_10_2_4_o
+@@ -10494,6 +10544,8 @@ static const struct wmi_ops wmi_10_2_4_o
ath10k_wmi_op_gen_pdev_enable_adaptive_cca,
.get_vdev_subtype = ath10k_wmi_10_2_4_op_get_vdev_subtype,
.gen_bb_timing = ath10k_wmi_10_2_4_op_gen_bb_timing,
/* .gen_bcn_tmpl not implemented */
/* .gen_prb_tmpl not implemented */
/* .gen_p2p_go_bcn_ie not implemented */
-@@ -10557,6 +10609,8 @@ static const struct wmi_ops wmi_10_4_ops
+@@ -10576,6 +10628,8 @@ static const struct wmi_ops wmi_10_4_ops
.gen_pdev_bss_chan_info_req = ath10k_wmi_10_2_op_gen_pdev_bss_chan_info,
.gen_echo = ath10k_wmi_op_gen_echo,
.gen_pdev_get_tpc_config = ath10k_wmi_10_2_4_op_gen_pdev_get_tpc_config,
};
int ath10k_wmi_attach(struct ath10k *ar)
---- a/ath10k-6.7/wmi.h
-+++ b/ath10k-6.7/wmi.h
-@@ -3133,6 +3133,41 @@ enum wmi_10_4_feature_mask {
+--- a/ath10k-6.9/wmi.h
++++ b/ath10k-6.9/wmi.h
+@@ -3137,6 +3137,41 @@ enum wmi_10_4_feature_mask {
};