bcm27xx: video: add BCM2835 Unicam video capture driver
authorPetr Štetiar <ynezz@true.cz>
Tue, 25 Feb 2020 14:47:37 +0000 (15:47 +0100)
committerPetr Štetiar <ynezz@true.cz>
Wed, 26 Feb 2020 10:02:39 +0000 (11:02 +0100)
Adds kernel module for Broadcom BCM2835 Unicam video capture driver.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/bcm27xx/modules/video.mk

index f1da7d83211b33939d724ef9f6ff672ee4fb84e6..1342c879a3f88ec93b1d93617dd34d9f0801365d 100644 (file)
@@ -24,6 +24,21 @@ endef
 $(eval $(call KernelPackage,camera-bcm2835))
 
 
+define KernelPackage/bcm2835-unicam
+  TITLE:=Broadcom BCM2835 Unicam video capture driver
+  KCONFIG:=CONFIG_VIDEO_BCM2835_UNICAM
+  FILES:=$(LINUX_DIR)/drivers/media/platform/bcm2835/bcm2835-unicam.ko
+  AUTOLOAD:=$(call AutoLoad,65,bcm2835-unicam)
+  $(call AddDepends/video,@TARGET_bcm27xx +kmod-video-videobuf2)
+endef
+
+define KernelPackage/camera-bcm2835/description
+  V4L2 subdevice for CSI2 receiver, that interfaces directly to the VC4 peripheral.
+endef
+
+$(eval $(call KernelPackage,bcm2835-unicam))
+
+
 define KernelPackage/drm-vc4
   SUBMENU:=$(VIDEO_MENU)
   TITLE:=Broadcom VC4 Graphics