projects
/
openwrt
/
staging
/
robimarko.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
2d86ea2
)
uci: work around a gcc bug which causes a bogus compiler warning
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 24 Dec 2008 17:25:21 +0000
(17:25 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 24 Dec 2008 17:25:21 +0000
(17:25 +0000)
SVN-Revision: 13739
package/uci/Makefile
patch
|
blob
|
history
diff --git
a/package/uci/Makefile
b/package/uci/Makefile
index 4d787ddfd2d40a88ed4767e4e0210ec0b005c201..69dd50baeae8e61f5185864287c493f79c61e349 100644
(file)
--- a/
package/uci/Makefile
+++ b/
package/uci/Makefile
@@
-56,6
+56,11
@@
UCI_MAKEOPTS = \
CPPFLAGS="-I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include" \
OS="Linux"
+# work around a nasty gcc bug
+ifneq ($(CONFIG_GCC_VERSION_4_2_4),)
+ UCI_MAKEOPTS += WOPTS=""
+endif
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) $(UCI_MAKEOPTS)
$(MAKE) -C $(PKG_BUILD_DIR)/lua $(UCI_MAKEOPTS)